automatic radio selection for reassign shouldn't trigger if new text is same as original owner or empty

RESOLVED FIXED in Bugzilla 2.16

Status

()

P3
enhancement
RESOLVED FIXED
18 years ago
6 years ago

People

(Reporter: jruderman, Assigned: caillon)

Tracking

unspecified
Bugzilla 2.16

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

18 years ago
Steps to reproduce:
0. have javascript turned on
1. go to an open bug
2. change e-mail address in 'assignee' box just above 'commit'
3. notice that js automatically selects the 'reassign' box for you (good)
4. change your mind, and select "resolve bug" instead
5. clear e-mail address for 'reassign', or change back to original owner, 
because you're worried that you might change something accidentally.
6. notice that js automatically selects the 'reassign' box for you (bad)

This is somewhere between minor and enhancement and "future me!!!".
(Reporter)

Comment 1

18 years ago
Same for resolve as duplicate.
Although not impossible to solve, this would be a fair bit of work compared to 
the existing code.  Right now it works with a very simple "onChange" handler.  If 
you change that field, it selects it. It doesn't care what you change it to.  To 
pull this off, you'd have to move the onChange handler into a separate 
subroutine, instead of having it all right in the INPUT tag.  You would also need 
an onLoad handler that grabbed the initial value of that field.  Once it's 
changed, the onChange handler would need to determine if it matched the initial 
value or not before deciding to select it.

*** This bug has been marked as a duplicate of 76161 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
OK, apparently this is harder.  We'll leave the duplicate issue over at bug
#76161 and keep this separate.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Target Milestone: --- → Bugzilla 2.16
->New product Bugzilla and taking.
Assignee: tara → caillon
Status: REOPENED → NEW
Really moving this time :)
Status: NEW → ASSIGNED
Component: Bugzilla → Creating/Changing Bugs
Product: Webtools → Bugzilla
Version: other → unspecified
I'm not sure what Dave was thinking of in his comments for this with the onload
stuff and separate subroutines, but this is a relatively simple patch which sets
the value of the assignee email into a JS var (since we're in JS anyway with the
onChange() handler), and then compare the newly entered value to the old value.

r= from someone?  :)
Keywords: patch, review

Comment 10

17 years ago
Comment on attachment 47984 [details] [diff] [review]
Simpler, better patch.

r=kiko looks much better now, harmless fix.
Attachment #47984 - Flags: review+

Comment 11

17 years ago
Applied to 

http://bugs.async.com.br/show_bug.cgi?id=130

So whoever verifies can test the validity of the fix.
Created attachment 47985 [details] [diff] [review]
Third time's a charm!  This also checks if the value is blank.
Attachment #47983 - Attachment is obsolete: true
Attachment #47984 - Attachment is obsolete: true
Comment on attachment 47985 [details] [diff] [review]
Third time's a charm!  This also checks if the value is blank.

r=bbaetz, and tested on the given bugzilla installation
Attachment #47985 - Flags: review+

Comment 14

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.