Basic Address Book search fails (quicksearch)

RESOLVED DUPLICATE of bug 298438

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 298438
8 years ago
7 years ago

People

(Reporter: Rolf Gloor, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 GTB5
Build Identifier: Thunderbird 3.0 RC1 build1

If Name sequence is not entered "perfectly", quicksearch will not work!
(No results)





Reproducible: Always

Steps to Reproduce:
1. Enter search name
2. press enter
3. watch result list
Actual Results:  
For "Muster, Peter u. Heidi" (Lastname: 'Muster', Firstname: Peter u. Heidi) none of the following search terms work:
- Peter Muster
- Peter, Muster
- Heidi Muster
- Heidi, Muster
- Muster, Peter
- Muster, Heidi

Despite showing as 'Muster, Peter u. Heidi'

Only the following works:
- Muster Peter  
- Muster Peter u. Heidi

So this search is not of a big help!

Expected Results:  
quicksearch to find also

- Peter Muster
- Peter, Muster
- Heidi Muster
- Heidi, Muster
- Muster, Peter
- Muster, Heidi
- Heidi Peter
- Peter Heidi
- and similars
(Reporter)

Updated

8 years ago
Blocks: 524434
Version: unspecified → 3.0
Whiteboard: dupeme

Comment 1

8 years ago
quick search is on Display Name. And search term is a single string, so only searches which are strict substrings of Muster, Peter u. Heidi return return results. "Muster, Peter" works for me if "Muster, Peter" is in display name

closest dupe is Bug 298438 -  Address book quick search should search in whole address card
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Summary: Basic Address Book Usage - Test case failed (quicksearch) → Basic Address Book search fails (quicksearch)
Duplicate of bug: 298438
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.