The default bug view has changed. See this FAQ.

pangox.h includes should be removed

RESOLVED FIXED in mozilla1.9.3a1

Status

()

Core
Graphics
--
trivial
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Nirbheek Chauhan, Assigned: Nirbheek Chauhan)

Tracking

1.9.2 Branch
mozilla1.9.3a1
x86
Linux
Points:
---

Firefox Tracking Flags

(status1.9.2 beta4-fixed)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b2) Gecko/20091112 Gentoo Firefox/3.6b2
Build Identifier: 

Sometime during the 1.9.1 cycle, pangox got replaced by pangoxft for fonts, but the headers are still around. pangox has been deprecated[1][2] upstream for a while now, hence there's no point keeping the header includes around.

This is part of our downstream (Gentoo) effort[3] to remove usage of pangox in ebuilds.

# pango/pangox.h is included
$ grep -re pangox\.h .
./config/system-headers:pango/pangox.h
./js/src/config/system-headers:pango/pangox.h
./gfx/src/thebes/nsThebesDeviceContext.cpp:#include <pango/pangox.h>

# But no pango_x_* functions are used
$ grep -re pango_x_ .
$

This seems to render bug 323671 obsolete as well.

1. http://git.gnome.org/cgit/pango/tree/pango/pangox.h#n33
2. http://library.gnome.org/devel/pango/stable/pango-X-Fonts-and-Rendering.html
3. http://bugs.gentoo.org/show_bug.cgi?id=293368

Reproducible: Always




I have tested that removing pangox.h from includes (and from the system) allows xulrunner to build without any problems, and firefox starts up without any problems as well.
(Assignee)

Updated

7 years ago
Version: unspecified → 1.9.2 Branch
Were you going to post the patch?
Component: Layout: Text → Graphics
QA Contact: layout.fonts-and-text → thebes
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

7 years ago
Created attachment 412656 [details] [diff] [review]
Remove pangox.h includes

Right, the patch is pretty straightforward :)
Attachment #412656 - Flags: approval1.9.2?
Attachment #412656 - Flags: review?(mozbugz)
Comment on attachment 412656 [details] [diff] [review]
Remove pangox.h includes

Thank you.  Please add the checkin-needed keyword if you'd like someone to push this to trunk.

This would be fine on 1.9.2 also, but that's not my decision to make.
Attachment #412656 - Flags: review?(mozbugz) → review+
(Assignee)

Comment 4

7 years ago
(In reply to comment #3)
> (From update of attachment 412656 [details] [diff] [review])
> Thank you.  Please add the checkin-needed keyword if you'd like someone to push
> this to trunk.
> 

Added, thank you for your help

> This would be fine on 1.9.2 also, but that's not my decision to make.

I added "wanted1.9.2 ?" since this also affects the ebuilds we have which use the official release packages (instead of building from source). Hence we'd like it if this could go into 1.9.2.
Flags: wanted1.9.2?
Keywords: checkin-needed

Updated

7 years ago
Assignee: nobody → nirbheek.chauhan
http://hg.mozilla.org/mozilla-central/rev/dca9a50280cd
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Comment on attachment 412656 [details] [diff] [review]
Remove pangox.h includes

a1.9.2=dbaron
Attachment #412656 - Flags: approval1.9.2? → approval1.9.2+
Keywords: checkin-needed
Whiteboard: [checkin needed for 1.9.2]
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/0887949e5215
status1.9.2: --- → final-fixed
Flags: wanted1.9.2?
Keywords: checkin-needed
Whiteboard: [checkin needed for 1.9.2]
You need to log in before you can comment on or make changes to this bug.