If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

After installation of 3.0.15, Access of RSS feed with no information does not work

RESOLVED INCOMPLETE

Status

()

Firefox
RSS Discovery and Preview
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: Dan McAfee, Unassigned)

Tracking

3.0 Branch
HP
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-05-10], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727)
Build Identifier: Zero Index Problem

When you access an RSS feed that has no information (links), you get prompted for bookmarking the RSS link.  It then stores the link incorrectly so that when you go to access the link, it asks you to bookmark the link and you go round and round.  All other RSS links work.  It is only in the case where you go to a link that is a dead end link (zero index) that you see this problem.

Reproducible: Always

Steps to Reproduce:
1. Happens on a classified area, so can't give you one you could use.
2. Find a RSS feed that has nothing at the other end (links or information).
Actual Results:  
The I.E. browser handles the exception without error and displays an empty page with a header that says there is nothing there.

Expected Results:  
Expect to see what the IE browser does with a dead end link/RSS feed.

Remember, this only happens is a unique case of a RSS feed that goes virtually nowhere and does nothing.  All other normal situations of RSS feeds works fine in bookmarking and navigating the RSS path.  

The exception handling needs to be tightened up.  This worked fine in 3.0.13.
(Reporter)

Updated

8 years ago
Priority: -- → P4
Hardware: x86 → HP
Version: unspecified → 3.0 Branch
I wonder if this was caused by

1.58	mozilla.mano%sent.com	2009-08-12 01:33	 	Bug 454363. a=ss

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=FeedWriter.js&branch=&root=/cvsroot&subdir=mozilla/browser/components/feeds/src&command=DIFF_FRAMESET&rev1=1.57&rev2=1.58

That's the only change I know of to RSS between 3.0.13 and 3.0.15.

Do you mean a blank feed with nothing in it at all or one that has tags and no content in them.
Dan, fixed in a newer version?

note Note: Priority should only be set by developers please. resetting to --
See https://bugzilla.mozilla.org/page.cgi?id=fields.html#priority
Priority: P4 → --
Whiteboard: [closeme 2010-05-10]
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.