Closed Bug 529491 Opened 10 years ago Closed 10 years ago

Can't edit draft occasionally with some combinations of addons

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: emoore, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091112 Thunderbird/3.0

I can not consistently edit a message that was saved in either my IMAP accounts drafts folder or a folder in local folder using 3.0RC1. Double clicking does nothing and the Edit button in the headers isn't always displayed. 

If I restart Thunderbird the first draft I select has an Edit button that works but double clicking does nothing. If I select a second message that always fails. 

If I run in safe mode the problem goes away and double clicking will also edit a draft. I've been trying to isolate which add-on causes the problem but I get inconsistent results. 

I got the problem to occur with only Personas 1.4 and Maximize Message Pane 0.9.100 add-on enabled. I disabled Personas and the problem didn't occur. I then re-enabled it and it didn't occur. I then enabled the "Silvermel and Charanel XT" 1.3.0 and "TB Header Edit Tools" 0.7 extensions and the problem came back. I then disabled everything except Persona 1.4 and "Silvermel and Charanel XT" 1.3.0 and the problem went away. I disabled all extensions except for Persona 1.4 and used the Nuvola 1.7.1+ theme and the problem didn't come back. This seems to rule out it being as simple as using Persona with a non-default theme.

Note: I restarted Thunderbird as necessary in the above steps when disabling and enabling.

I have the version limit checking disabled so that I can use older extensions/themes. I'm sharing the same profile with several versions of Thunderbird. 2.0.0.23 never has this problem. Shredder beta 4 and the 200091113 Shredder nightly build has this problem. 

Since Personas can't run under 2.0.0.23 and I never saw this problem before I installed it I suspect its somehow due to using Personas with certain extensions (not themes). I'll do some more testing and update this later on.



Reproducible: Sometimes
Blocks: qa-tb3.0rc1
nothing in error console?
Component: Mail Window Front End → Message Compose Window
QA Contact: front-end → message-compose
Summary: Can't edit draft → Can't edit draft occasionally with some combinations of addons
Version: unspecified → 3.0
Not thunderbird related issue: is a support request. See here http://getsatisfaction.com/mozilla_messaging
Whiteboard: [support]
Eric - can you try to pinpoint which combination of add-on produce this issue ?
I'll try again using the current version of the add-ons. I had isolated it before to requiring both the Personas 1.4 and Maximize Message Pane 0.9.100 extensions while not using certain themes (Nuvola 1.7.1+ didn't cause a problem). I don't remember anything useful in the error console, just the normal warnings. 

Where can I get a nightly or beta build of Personas? I'd like to try it with that too. I'm currently using 1.5.1 (latest release)
:Aureliano Buendía 
This was not a support request. I was trying to report what I thought might be a bug in Thunderbird, or some dependency that add-on developers might need to know about. 

Ludovic Hirlimann:
I can't duplicate the problem anymore. I tested with 3.0.1 and 20100220 Shredder/3.0.3pre.  I'm going to change the status to resolved/fixed.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
WFM since no known patch
Resolution: FIXED → WORKSFORME
Whiteboard: [support]
You need to log in before you can comment on or make changes to this bug.