perma-orange: assertion failure (or timeout) in a11y mochitests: v == LOCKED_OBJ_GET_SLOT(pobj, sprop->slot)

RESOLVED FIXED in mozilla1.9.3a1

Status

()

defect
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: dbaron, Assigned: brendan)

Tracking

({intermittent-failure})

Trunk
mozilla1.9.3a1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(2 attachments)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258640014.1258647001.6272.gz
Linux mozilla-central debug test everythingelse on 2009/11/19 06:13:34  
rev: http://hg.mozilla.org/mozilla-central/rev/5b631f59dda3

1241 INFO TEST-PASS | chrome://mochikit/content/a11y/accessible/test_invalidate_elmli.html | test with ID = 'show HTML li' failed. No show event.
Assertion failure: v == LOCKED_OBJ_GET_SLOT(pobj, sprop->slot), at /builds/slave/mozilla-central-linux-debug/build/js/src/jsinterp.cpp:202


 1  libmozjs.so!JS_Assert [jsutil.cpp:5b631f59dda3 : 70 + 0xb]
    eip = 0x00304925   esp = 0xbfc5a410   ebp = 0xbfc5a428
    Found by: previous frame's frame pointer
 2  libmozjs.so!js_FillPropertyCache [jsinterp.cpp:5b631f59dda3 : 202 + 0xc3]
    eip = 0x002891ac   esp = 0xbfc5a430   ebp = 0xbfc5a4b8
    Found by: previous frame's frame pointer
 3  libmozjs.so!js_GetPropertyHelper [jsobj.cpp:5b631f59dda3 : 4487 + 0x36]
    eip = 0x0029ccc8   esp = 0xbfc5a4c0   ebp = 0xbfc5a518
    Found by: previous frame's frame pointer
 4  libmozjs.so!js_GetMethod [jsobj.cpp:5b631f59dda3 : 4510 + 0x26]
    eip = 0x0029cdd2   esp = 0xbfc5a520   ebp = 0xbfc5a558
    Found by: previous frame's frame pointer
 5  libmozjs.so!js_Interpret [jsops.cpp:5b631f59dda3 : 1645 + 0x52]
    eip = 0x00270b87   esp = 0xbfc5a560   ebp = 0xbfc5ab58
    Found by: previous frame's frame pointer
 6  libmozjs.so!js_Invoke [jsinvoke.cpp:5b631f59dda3 : 1384 + 0xa]
    eip = 0x00288032   esp = 0xbfc5ab60   ebp = 0xbfc5ac48
    Found by: previous frame's frame pointer
 7  libxul.so!nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS*, unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*) [xpcwrappedjsclass.cpp:5b631f59dda3 : 1696 + 
    eip = 0x00e5ec34   esp = 0xbfc5ac50   ebp = 0xbfc5aff8
    Found by: previous frame's frame pointer
 8  libxul.so!nsXPCWrappedJS::CallMethod(unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*) [xpcwrappedjs.cpp:5b631f59dda3 : 570 + 0x35]
    eip = 0x00e55821   esp = 0xbfc5b000   ebp = 0xbfc5b028
    Found by: previous frame's frame pointer
 9  libxul.so!PrepareAndDispatch [xptcstubs_gcc_x86_unix.cpp:5b631f59dda3 : 95 + 0x3a]
    eip = 0x0208ca9a   esp = 0xbfc5b030   ebp = 0xbfc5b118
    Found by: previous frame's frame pointer
10  libxul.so!nsThread::ProcessNextEvent(int, int*) [nsThread.cpp:5b631f59dda3 : 527 + 0x18]
    eip = 0x02070759   esp = 0xbfc5b120   ebp = 0xbfc5b188
    Found by: previous frame's frame pointer
11  libxul.so!NS_ProcessNextEvent_P(nsIThread*, int) [nsThreadUtils.cpp : 250 + 0x1f]
    eip = 0x020065cc   esp = 0xbfc5b190   ebp = 0xbfc5b1c8
    Found by: previous frame's frame pointer
12  libxul.so!nsBaseAppShell::Run() [nsBaseAppShell.cpp:5b631f59dda3 : 170 + 0x12]
    eip = 0x01ed1e8e   esp = 0xbfc5b1d0   ebp = 0xbfc5b208
    Found by: previous frame's frame pointer
13  libxul.so!nsAppStartup::Run() [nsAppStartup.cpp:5b631f59dda3 : 182 + 0x1b]
    eip = 0x01c4c369   esp = 0xbfc5b210   ebp = 0xbfc5b248
    Found by: previous frame's frame pointer
14  libxul.so!XRE_main [nsAppRunner.cpp:5b631f59dda3 : 3491 + 0x1b]
    eip = 0x00de929c   esp = 0xbfc5b250   ebp = 0xbfc5b808
    Found by: previous frame's frame pointer
15  firefox-bin!main [nsBrowserApp.cpp:5b631f59dda3 : 158 + 0x1d]
    eip = 0x08048e32   esp = 0xbfc5b810   ebp = 0xbfc5b878
    Found by: previous frame's frame pointer
Whiteboard: [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258643242.1258648613.24170.gz
Linux mozilla-central debug test everythingelse on 2009/11/19 07:07:22  

1241 INFO TEST-PASS | chrome://mochikit/content/a11y/accessible/test_invalidate_elmli.html | test with ID = 'show HTML li' failed. No show event.
Assertion failure: v == LOCKED_OBJ_GET_SLOT(pobj, sprop->slot), at /builds/moz2_slave/mozilla-central-linux-debug/build/js/src/jsinterp.cpp:202

...

 1  libmozjs.so!JS_Assert [jsutil.cpp:24ddb9b3d3ed : 70 + 0xb]
    eip = 0x00233925   esp = 0xbf9ff1b0   ebp = 0xbf9ff1c8
    Found by: previous frame's frame pointer
 2  libmozjs.so!js_FillPropertyCache [jsinterp.cpp:24ddb9b3d3ed : 202 + 0xc3]
    eip = 0x001b81ac   esp = 0xbf9ff1d0   ebp = 0xbf9ff258
    Found by: previous frame's frame pointer
 3  libmozjs.so!js_GetPropertyHelper [jsobj.cpp:24ddb9b3d3ed : 4487 + 0x36]
    eip = 0x001cbcc8   esp = 0xbf9ff260   ebp = 0xbf9ff2b8
    Found by: previous frame's frame pointer
 4  libmozjs.so!js_GetMethod [jsobj.cpp:24ddb9b3d3ed : 4510 + 0x26]
    eip = 0x001cbdd2   esp = 0xbf9ff2c0   ebp = 0xbf9ff2f8
    Found by: previous frame's frame pointer
...
On Windows it seems to be showing uup as a timeout rather than an as an assertion failure:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258642928.1258649496.1741.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/19 07:02:08
"s: moz2-win32-slave34"


1242 INFO TEST-PASS | chrome://mochikit/content/a11y/accessible/test_invalidate_elmli.html | test with ID = 'show HTML li' failed. No show event.

command timed out: 1200 seconds without output




http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258639829.1258648717.25457.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/19 06:10:29  
"s: moz2-win32-slave06"

1242 INFO TEST-PASS | chrome://mochikit/content/a11y/accessible/test_invalidate_elmli.html | test with ID = 'show HTML li' failed. No show event.

command timed out: 1200 seconds without output
Summary: random orange: assertion failure in a11y mochitests: v == LOCKED_OBJ_GET_SLOT(pobj, sprop->slot) → random orange: assertion failure (or timeout) in a11y mochitests: v == LOCKED_OBJ_GET_SLOT(pobj, sprop->slot)
As far as I can tell this is perma-orange; it's been happening for at least 12 hours and many of the failures have been starred based on the other failures in the log, and people have been ignoring this one.
Summary: random orange: assertion failure (or timeout) in a11y mochitests: v == LOCKED_OBJ_GET_SLOT(pobj, sprop->slot) → perma-orange: assertion failure (or timeout) in a11y mochitests: v == LOCKED_OBJ_GET_SLOT(pobj, sprop->slot)
Disabling the joined function optimization again on m-c.

/be
Assignee: general → brendan
Blocks: 524826
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86 → All
Target Milestone: --- → mozilla1.9.3a1
http://hg.mozilla.org/mozilla-central/rev/729a894a635b

I'll undo when the fix lands.

/be
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258652539.1258661047.8693.gz
Linux mozilla-central debug test everythingelse on 2009/11/19 09:42:19  

(one cycle before the above landed)
Duplicate of this bug: 529827
Attachment #413567 - Flags: review?(jorendorff)
Comment on attachment 413567 [details] [diff] [review]
face-palm time

Phew.
Attachment #413567 - Flags: review?(jorendorff) → review+
http://hg.mozilla.org/tracemonkey/rev/6daf3a51df56

Still need to undo the hackaround disabling the joined-function optimization in mozilla-central and land there, after the 3.6 freeze ends.

/be
Whiteboard: [orange] → [orange] fixed-in-tracemonkey
(In reply to comment #12)
> http://hg.mozilla.org/tracemonkey/rev/6daf3a51df56
> 
> Still need to undo the hackaround disabling the joined-function optimization in
> mozilla-central and land there, after the 3.6 freeze ends.

Undone:

http://hg.mozilla.org/mozilla-central/rev/6b433a097f16

and in tm, since m-c got merged into tm bringing the hackaround with it.

Is this bug fixed in m-c now? Looks like I'd better land, pronto.

http://hg.mozilla.org/mozilla-central/rev/67ba33b024f4

Sigh, with wrong commit message.

/be
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Depends on: 537854
Whiteboard: [orange] fixed-in-tracemonkey → fixed-in-tracemonkey
You need to log in before you can comment on or make changes to this bug.