Last Comment Bug 529933 - [Mac] "File" toolbar button shows old folder after bug 491294
: [Mac] "File" toolbar button shows old folder after bug 491294
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: Thunderbird 12.0
Assigned To: Andreas Nilsson (:andreasn)
:
Mentors:
Depends on:
Blocks: 491294
  Show dependency treegraph
 
Reported: 2009-11-19 14:12 PST by Thomas Stache
Modified: 2012-01-25 01:25 PST (History)
4 users (show)
standard8: blocking‑thunderbird3-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
new folder icons for main toolbar and compose window (230.05 KB, patch)
2009-11-20 03:23 PST, Andreas Nilsson (:andreasn)
bwinton: review+
clarkbw: ui‑review+
Details | Diff | Review
screenshot of before and after (109.48 KB, image/png)
2009-11-20 07:02 PST, Andreas Nilsson (:andreasn)
no flags Details
new folder icons for main toolbar and compose window (v2) (236.98 KB, patch)
2012-01-24 05:55 PST, Andreas Nilsson (:andreasn)
bugs: review+
bugs: ui‑review+
Details | Diff | Review

Description Thomas Stache 2009-11-19 14:12:28 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3
Build Identifier: 

Bug 491294 brought updated Leopard-style folder icons for the folder pane, the compose window toolbar and probably some more. But the "File..." button on the main toolbar was omitted.

Reproducible: Always
Comment 1 Andreas Nilsson (:andreasn) 2009-11-20 03:23:36 PST
Created attachment 413580 [details] [diff] [review]
new folder icons for main toolbar and compose window
Comment 2 Andreas Nilsson (:andreasn) 2009-11-20 07:02:55 PST
Created attachment 413611 [details]
screenshot of before and after

to ease ui review
Comment 3 Mark Banner (:standard8) 2009-11-20 10:50:11 PST
Not blocking on this, though we could potentially take it for a point release of 3.0 (undecided as of yet).
Comment 4 Bryan Clark (DevTools PM) [@clarkbw] 2009-11-20 15:18:39 PST
Comment on attachment 413580 [details] [diff] [review]
new folder icons for main toolbar and compose window

looks good from the screenshots, thanks andreas!
Comment 5 :aceman 2011-10-17 02:47:48 PDT
Comment on attachment 413580 [details] [diff] [review]
new folder icons for main toolbar and compose window

Confirming per the comments.
Was this patch integrated or not?
Comment 6 Mark Banner (:standard8) 2011-10-17 03:52:19 PDT
Comment on attachment 413580 [details] [diff] [review]
new folder icons for main toolbar and compose window

Please don't ask by requesting review, just ask the author of the patch (making sure they are cc'ed or assigned), if it is still wanted.
Comment 7 Andreas Nilsson (:andreasn) 2011-10-17 09:31:17 PDT
Comment on attachment 413580 [details] [diff] [review]
new folder icons for main toolbar and compose window

Totally forgot about this bug.
Asking bwinton for review here.
Comment 8 Blake Winton (:bwinton) (:☕️) 2011-10-17 09:38:40 PDT
Comment on attachment 413580 [details] [diff] [review]
new folder icons for main toolbar and compose window

Review of attachment 413580 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, although I admit I haven't tested out the patch on a recent build.

I'm going to say r=me, but I would like to see a link to a try-server build that I could run a quick check on.  :)
Comment 10 Ludovic Hirlimann [:Usul] 2011-10-24 01:09:17 PDT
(In reply to Andreas Nilsson (:andreasn) from comment #9)
> Here you go!
> 
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/try-builds/nisses.
> mail@home.se-31f8aa7f478e/try-comm-central-macosx-debug/
Comment 11 Ludovic Hirlimann [:Usul] 2012-01-18 07:17:00 PST
Why is this not checked-in ?
Comment 12 :aceman 2012-01-18 07:21:16 PST
checkin-needed missing?
Comment 13 Mark Banner (:standard8) 2012-01-18 10:00:17 PST
I suspect forgotten or was waiting for Blake to test.

In any case, I suspect it needs a new patch (andreasn?)
Comment 14 Andreas Nilsson (:andreasn) 2012-01-24 05:32:16 PST
Yup, graphics needs to be slightly updated, since we got at least one new icon on the toolbar.
Comment 15 Andreas Nilsson (:andreasn) 2012-01-24 05:55:29 PST
Created attachment 591068 [details] [diff] [review]
new folder icons for main toolbar and compose window (v2)

new patch. Carrying over review and ui-review.
Comment 16 Ludovic Hirlimann [:Usul] 2012-01-24 07:36:46 PST
so adding the checkin-needed :-)
Comment 17 Mark Banner (:standard8) 2012-01-25 01:25:30 PST
Checked in: http://hg.mozilla.org/comm-central/rev/feb02f829940

Note You need to log in before you can comment on or make changes to this bug.