Fail to send emails with joined file that are edited with Edit as new, Drafts or Templates

RESOLVED DUPLICATE of bug 501298

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 501298
8 years ago
6 years ago

People

(Reporter: Robert Monnier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla Thunderbird 2.0.0.23 (20090812)

When editing from Drafts or Templates or a previously sent message opened with Edit as new, the message containing a joined JPG file (such as an invitation), the message to be sent as HTML only, if the editing takes more than a few minutes, when Sending, an error message appears : [Send Message Error | Sending of message failed | There was an error attaching . Please check if you have access to the file]. Message cannot be sent. If an attempt is made to Save the message (therefore keeping the specific text added to the message) another error window shows : [Save draft error | Unable to save your message as draft | There was an error attaching . Please check if you have access to the file]. There actually is a saved copy of the message in Drafts. Is this problem related with Auto Save ??? Please note in the Error messages that the name of the file is omitted. This description is base on Mac. On a Windows machine, a previous progress window is showed : (sorry the text is in French here, I will not try to translate it ) [Envoie de message - (title of the message) | Statut : Adjonction de ... | Progression : (Progress bar) | Cancel button ]

Reproducible: Always

Steps to Reproduce:
1. Prepare an email with an inserted file, save in Drafts, or in Templates
2. Edit the email from Drafts, or Templates
3. Change the email - sendee, specific message ... make sure it takes a couple of minutes ...
4. Send the email

Actual Results:  
An error window appears indicating that the file cannot be attached. OK button to close the window. Message fails to be sent. If attempt to save the message, error window indicating file cannot be attached (Please check if you have access to the file). Message cannot be sent.

Expected Results:  
The email should have been sent, or saved.

Turnaround : 
1. Close the error window
2. Select and copy the specific message that has been added
3. Close the message without saving (it wouldn't save and would show the same error message)
4. Go to the Drafts folder : a version of the failed message will be found there, but perhaps with incomplete edits
5. Open (double-click) that saved message
6. If incomplete, select the specific message and paste the completed specific message
7. Send
Is your draft folder on imap or a local folder ?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Is your draft folder on imap or a local folder ?

Local folder.

I tried to play with the AutoSave delay (setting it to 10') and although it gives a respite it's not a solution.

Thanks for looking at this.
Robert Monnier
(Reporter)

Comment 3

8 years ago
Strong similarity to  Bug 501298 - different analysis.
(In reply to comment #3)
> Strong similarity to  Bug 501298 - different analysis.

Do you think it's the same issue ?

Anything in the Tools -> Error console when this happens ?

What's the size of your draft folder ?
(Reporter)

Comment 5

8 years ago
Yes I think it's the same issue.

The Drafts folder is of not significant size, zero or one or two items lingering there. Templates folder with only one item - the one that it won't be possible to send if the editing has taken too long. Sent and Inbox are pretty humongous, even with attachments deleted, and folders compressed from time to time.

This problem has occured on XP as well as on OS X 10.4.

I have reproduced the problem and checked the Error console after having emptied it previously - nothing found.
(Reporter)

Comment 6

8 years ago
A different way to trigger this problem : 
1. Choose a message with an included file in the Sent folder and open it for editing with Edit As New
2. Change something
3. Click Save
4. Click Send ...

Message can't be sent. Check that you have access to ... etc.

Now to be perfectly clear, and I don't know if I have the right terminology, the body of the message is HTML, with a bit of text that can be edited according to the receiver, and a .jpg file (that will be readable directly in the message by the receiver), and a short address text at the end.

I haven't been able to reproduce this problem with a plain text body and an attachment.
(Reporter)

Comment 7

8 years ago
I retract myself, this is what I found in the error log :

Erreur : [Exception... "'Failure' when calling method: [gIMsgFolder::GetMessageHeader]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "<unknown>"  data: no]

Erreur : [Exception... "Component returned failure code: 0x80550006 [nsIMsgFolder.getMessages]"  nsresult: "0x80550006 (<unknown>)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Thunderbird/components/GoogleDesktopMozillaStub.js :: anonymous :: line 159"  data: no]
Fichier source : file:///C:/Program%20Files/Mozilla%20Thunderbird/components/GoogleDesktopMozillaStub.js
Ligne : 159

Erreur : [Exception... "Component returned failure code: 0x80550006 [nsIMsgFolder.getMessages]"  nsresult: "0x80550006 (<unknown>)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Thunderbird/components/GoogleDesktopMozillaStub.js :: anonymous :: line 159"  data: no]
Fichier source : file:///C:/Program%20Files/Mozilla%20Thunderbird/components/GoogleDesktopMozillaStub.js
Ligne : 159

Erreur : [Exception... "'Failure' when calling method: [gIMsgFolder::GetMessageHeader]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "<unknown>"  data: no]

Erreur : [Exception... "'Failure' when calling method: [gIMsgFolder::GetMessageHeader]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "<unknown>"  data: no]
Can you update google desktop or make sure it doesn't try to index Thunderbird emails fro now ?
(Reporter)

Comment 9

8 years ago
(In reply to comment #8)
> Can you update google desktop or make sure it doesn't try to index Thunderbird
> emails fro now ?

Updated Google Desktop from 5.7.0806.10245-en-pb to 5.9.0911.03589-fr-pb. It doesn't change anything to the problem. Same behaviour on XP and on OS X 10.4, and on the Mac there isn't Google Desktop.
(In reply to comment #9)
> (In reply to comment #8)
> > Can you update google desktop or make sure it doesn't try to index Thunderbird
> > emails fro now ?
> 
> Updated Google Desktop from 5.7.0806.10245-en-pb to 5.9.0911.03589-fr-pb. It
> doesn't change anything to the problem. Same behaviour on XP and on OS X 10.4,
> and on the Mac there isn't Google Desktop.
But you don't get the same issues in the Error console ?
(Reporter)

Comment 11

8 years ago
> > Updated Google Desktop from 5.7.0806.10245-en-pb to 5.9.0911.03589-fr-pb. It
> > doesn't change anything to the problem. Same behaviour on XP and on OS X 10.4,
> > and on the Mac there isn't Google Desktop.
> But you don't get the same issues in the Error console ?

I haven't compared Error console in XP and OS X, I'm with the XP machine and will not be able to try with the OS X before tomorrow. If that is exactly your question.

Otherwise, I cannot vouch that what Error console reported was the same before and after I updated Google Desktop.
(Reporter)

Comment 12

8 years ago
I've been reproducing this problem on an Intel Mac with OX X 10.4 and Thunderbird 2.0.0.23 and have found no trace of it in the error log. The message doesn't send with exactly the same messages, but nothing appears in the error log.

Comment 13

8 years ago
please add detail to the summary please with something more descriptive for the word "problem". thx.
(Reporter)

Updated

8 years ago
Summary: Problem with joined file in editing from Sent/Edit as new, Drafts or Templates → Fail to send emails with joined file that are edited with Edit as new, Drafts or Templates

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501298
You need to log in before you can comment on or make changes to this bug.