The default bug view has changed. See this FAQ.

Search for "Age in days" uses "is" with "is less than" default, works fine when manually selected

RESOLVED FIXED in seamonkey2.1a1

Status

SeaMonkey
MailNews: Message Display
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: rsx11m, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey2.0.1})

Trunk
seamonkey2.1a1
fixed-seamonkey2.0.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
I found this while testing for bug 530403 on the Thunderbird counterpart.

If you enter the search dialog and switch the search term to "Age in days", not touching the default "is less than", you get a different search result than if explicitly selecting that option from the menu.

Steps to reproduce:
1. Search in a local folder with some messages less than n days old;
2. select "Age in days", default goes to "is less than";
3. enter a number n and click Search;
4. only a few results - if any - are shown (still looking for "is" instead?);
5. select "is more than" and go back to "is less than";
6. Search now shows the correct list of results.

The default was changed from "is" by bug 187741.
(Reporter)

Comment 1

7 years ago
Some more testing (current nightly build), indeed the "is" filter is used when the "is less than" default is left unchanged (both IMAP and Local Folders).
Summary: Search for "Age in days" doesn't work right with "is less than" default → Search for "Age in days" uses "is" with "is less than" default, works fine when manually selected
(Assignee)

Comment 2

7 years ago
Created attachment 413936 [details] [diff] [review]
Proposed patch

So much for my original "fix" :-(
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #413936 - Flags: review?(mnyromyr)
(Reporter)

Updated

7 years ago
OS: Windows XP → All
Hardware: x86 → All

Updated

7 years ago
Attachment #413936 - Flags: review?(mnyromyr)
Attachment #413936 - Flags: review+
Attachment #413936 - Flags: approval-seamonkey2.0.1+
(Assignee)

Comment 3

7 years ago
Pushed changeset 0ee062df1a25 to comm-central.

Pushed changeset 9bca5aa6d303 to releases/comm-1.9.1
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: fixed-seamonkey2.0.1
Resolution: --- → FIXED

Updated

7 years ago
Target Milestone: --- → seamonkey2.1a1
Blocks: 530403

Updated

6 years ago
Duplicate of this bug: 529553
You need to log in before you can comment on or make changes to this bug.