Last Comment Bug 530416 - Replace PR_MIN/PR_MAX with NS_MIN/NS_MAX in the rest of mozilla-central
: Replace PR_MIN/PR_MAX with NS_MIN/NS_MAX in the rest of mozilla-central
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- minor (vote)
: ---
Assigned To: Jae-Seong Lee-Russo
:
:
Mentors:
Depends on:
Blocks: 518502
  Show dependency treegraph
 
Reported: 2009-11-22 08:19 PST by Jae-Seong Lee-Russo
Modified: 2011-07-06 15:37 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Search&Replace, 0 (2.84 KB, patch)
2009-11-22 08:19 PST, Jae-Seong Lee-Russo
benjamin: review-
Details | Diff | Splinter Review

Description Jae-Seong Lee-Russo 2009-11-22 08:19:07 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091120 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Build Identifier: 

Please see Bug #512106.

Reproducible: Always
Comment 1 Jae-Seong Lee-Russo 2009-11-22 08:19:41 PST
Created attachment 413926 [details] [diff] [review]
Search&Replace, 0
Comment 2 Dão Gottwald [:dao] 2010-03-25 14:27:03 PDT
Comment on attachment 413926 [details] [diff] [review]
Search&Replace, 0

I'm not the right reviewer for this
Comment 3 Brendan Eich [:brendan] 2010-03-26 19:27:00 PDT
Comment on attachment 413926 [details] [diff] [review]
Search&Replace, 0

Why is Mork still darkening our source tree?

I defer to Benjamin on this kind of patch.

/be
Comment 4 Benjamin Smedberg [:bsmedberg] 2010-04-06 10:29:56 PDT
Comment on attachment 413926 [details] [diff] [review]
Search&Replace, 0

As I noted in one of these bugs, I do not think NS_MIN/MAX are good names (because they still look like macros). There is a patch (reviewed, perhaps?) in one of these bugs to make mozilla::min/max and use that.
Comment 5 Ed Morley [:emorley] 2011-07-06 15:36:55 PDT
Fixed by bug 661584.

Note You need to log in before you can comment on or make changes to this bug.