Last Comment Bug 518502 - Replace PR_MIN/PR_MAX with NS_MIN/NS_MAX, in mozilla-central
: Replace PR_MIN/PR_MAX with NS_MIN/NS_MAX, in mozilla-central
Status: VERIFIED FIXED
: meta
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- minor (vote)
: ---
Assigned To: Jae-Seong Lee-Russo
:
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on: 512106 518504 530290 530293 530296 530297 530299 530300 530305 530360 530361 530363 530364 530372 530373 530374 530375 530382 530384 530385 530386 530387 530389 530392 530394 530408 530409 530410 530411 530415 530416 661584
Blocks: 707396 707395 708274 708277
  Show dependency treegraph
 
Reported: 2009-09-23 20:54 PDT by Serge Gautherie (:sgautherie)
Modified: 2011-12-07 09:24 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Replace PR_MIN/PR_MAX with NS_MIN/NS_MAX in mozilla-central (263.90 KB, patch)
2009-09-25 12:26 PDT, Jae-Seong Lee-Russo
no flags Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2009-09-23 20:54:28 PDT
+++ This bug was initially created as a clone of Bug #512106 +++

See that bug about why and how to do it...
Comment 1 Jae-Seong Lee-Russo 2009-09-25 12:26:19 PDT
Created attachment 402894 [details] [diff] [review]
Replace PR_MIN/PR_MAX with NS_MIN/NS_MAX in mozilla-central

Automatically replaced PR_MIN/PR_MAX, and then had to add changes manually (#include "nsAlgorithm.h", type conversions).

I could build Firefox on Windows XP.  The patch needs to be tested on the Try Server.
Comment 2 Dão Gottwald [:dao] 2009-11-19 05:13:12 PST
This patch doesn't apply anymore:

patching file xpcom/string/src/nsTSubstring.cpp
Hunk #1 succeeded at 475 (offset 1 line).
Hunk #3 succeeded at 526 (offset 1 line).
Hunk #4 FAILED at 544.

http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1258635928.1258636234.11984.gz
Comment 3 Ed Morley [:emorley] 2011-07-06 15:35:48 PDT
Fixed by bug 661584.
Comment 4 Serge Gautherie (:sgautherie) 2011-07-06 18:17:07 PDT
To be explicit, what about (other) remaining cases? (Mostly in (NSPR and) NSS.)

"Found 38 matching lines in 11 files "
Comment 5 Ed Morley [:emorley] 2011-07-07 03:41:04 PDT
The others are in NSS/NSPR (which I was under the impression can't use a core specific include, due to third party users of them) & non C++ code. As such, I don't believe any of the others can be changed - though if that is not the case, I'm happy to try and implement whatever you suggest.
Comment 6 Serge Gautherie (:sgautherie) 2011-12-02 19:13:35 PST
(In reply to Ed Morley [:edmorley] from comment #5)
> The others are in NSS/NSPR (which I was under the impression can't use a
> core specific include, due to third party users of them) & non C++ code. As
> such, I don't believe any of the others can be changed - though if that is
> not the case, I'm happy to try and implement whatever you suggest.

Right: "Found 39 matching lines in 12 files"
/modules/libreg/src/nr_bufio.c
/ipc/chromium/src/base/third_party/nspr/prtypes.h
2 * /nsprpub/pr/...
/docshell/shistory/src/nsSHistory.cpp : I filed bug 707395.
7 * /security/nss/

V.Fixed
Comment 7 Serge Gautherie (:sgautherie) 2011-12-07 09:24:37 PST
(In reply to Serge Gautherie (:sgautherie) from comment #6)
> V.Fixed

Arg, I probably checked PR_MIN only :-/
I filed 2  new blocking bugs!

Note You need to log in before you can comment on or make changes to this bug.