Last Comment Bug 531001 - Vertical view is not really usable in thunderbird 3
: Vertical view is not really usable in thunderbird 3
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-24 23:24 PST by Hubert FONGARNAND
Modified: 2011-09-16 17:16 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot showing the problem (106.33 KB, image/png)
2009-11-24 23:25 PST, Hubert FONGARNAND
no flags Details

Description Hubert FONGARNAND 2009-11-24 23:24:36 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.5) Gecko/20091109 Ubuntu/9.10 (karmic) Firefox/3.5
Build Identifier: 

This is clearly a regression from thunderbird 2...

in TB 3, if you use vertical mode... half of the new "message toolbar" (reply, forward, delete) is hidden, the From field is totally hidden...
I think this mode should be rethinked...

Many people on our firm use vertical view in TB2... i can't say : "with TB3 this mode would be worst than before..."

Reproducible: Always

Steps to Reproduce:
1. Hava a 4/3 screen resolution 1280x1024
2. Switch on vertical mode
3. Click on message
Actual Results:  
half of the new "message toolbar" (reply, forward, delete) is hidden, the From field is totally hidden...

Expected Results:  
We should see at least the "from" field and the toolbar should be usable
Comment 1 Hubert FONGARNAND 2009-11-24 23:25:13 PST
Created attachment 414460 [details]
Screenshot showing the problem
Comment 2 Hubert FONGARNAND 2009-11-24 23:25:42 PST
The same problem exists in windows...
Comment 3 Thomas Bertels 2009-12-16 13:39:32 PST
A workaround would be to customize it with CustomizeHeaderToolbar https://addons.mozilla.org/fr/thunderbird/addon/45601 and add the needed buttons to the main toolbar.
Comment 4 Andrew Jeffery 2009-12-17 21:28:51 PST
I came to report the same thing

(In reply to comment #3)
> A workaround would be to customize it with CustomizeHeaderToolbar
> https://addons.mozilla.org/fr/thunderbird/addon/45601 and add the needed
> buttons to the main toolbar.

The problem isn't missing buttons but that the buttons are covering the header fields. However using this extension you can set the buttons to "Icon" only mode which shrinks them a lot.

Still, I think the buttons should maybe appear above the header information, though this has the disadvantage of increasing the vertical size of the header bar (it already seems pretty large when using the "Classic" layout)
Comment 5 mr_johnson_privacy_first 2010-04-18 01:39:36 PDT
I can confirm this for the popular "tablet PCs" like the 1825PT(Z) or the T101MT. Working around this with added buttons to the top menu bar works. But this really needs to be worked out. Maybe TB can switch to another window layout automatically depending on the screen format/rotation. (Then it would be quite similar to what the new apple product does...possible? patent wise?)
Comment 6 Jim Porter (:squib) 2011-01-14 00:00:48 PST
Fixed by bug 519956 and bug 530047?
Comment 7 Jim Porter (:squib) 2011-09-16 17:16:58 PDT
Marking fixed based on comment 6; if you still see the issue, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.