Closed Bug 531140 Opened 11 years ago Closed 11 years ago

styling in message view select widget and folder location select widget a mess

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows 7
defect
Not set
minor

Tracking

(thunderbird3.1 wanted)

RESOLVED FIXED
Thunderbird 3.3a1
Tracking Status
thunderbird3.1 --- wanted

People

(Reporter: asa, Assigned: andreasn)

References

Details

Attachments

(5 files)

The style for text and selection in the message view widget and the folder location select widget is a mess. It shows three wrong styles. First, it's white on white in some cases. Second it's black on blue in some cases. Third it's white on blue in some cases. Fourth, the background and border is not the correct style either and there's no space for icons.

The correct selection color is a blue outline on the selected item with black text.
Flags: blocking-thunderbird3?
Not going to block 3.0 for this, but we want a patch for an expected quick turn around 3.0.1 release.
Assignee: nobody → nisses.mail
blocking-thunderbird3.0: --- → .1
Flags: blocking-thunderbird3? → blocking-thunderbird3-
Attached image native windows dropdown
I wonder if all the wrongs in the example are really wrongs. Looking around in other Vista apps it seems like dropdowns tend to look this way across the system.
The one that changes color is indeed a issue though.
To follow up, as these are  menulists rather than a menus, it should probably be solid blue hover on white background as seen in the current folder location dropdown.

The odd blue rounded hovers with white text seems to be because the controls are using type="radio" in extraCustomizeItems.xul (and sometimes checkboxes?). Still investigating on how to fix that.
Not sure what to do with the submenus, as I can't find any other examples on a situation where these are used in menuitems, but it would probably make sense to make these use solid blue on white instead of mimicking regular menus.
Attached patch possible fixSplinter Review
I'm not quite certain about this approach, as it might be better handled in the global toolkit bits (?), but it takes care of the color issue at least.
Attachment #417702 - Flags: ui-review?(clarkbw)
Attachment #417702 - Flags: review?(philringnalda)
Duplicate of this bug: 533755
Whiteboard: [needs review clarkbw,philor]
blocking-thunderbird3.0: .1+ → needed
Comment on attachment 417702 [details] [diff] [review]
possible fix

I would love a screenshot of this as I don't have windows 7 to test with
(In reply to comment #6)
> (From update of attachment 417702 [details] [diff] [review])
> I would love a screenshot of this as I don't have windows 7 to test with

Andreas: ping for the above.
Comment on attachment 417702 [details] [diff] [review]
possible fix

Ok, that looks better to me.  Perhaps we keep this bug open for further issues we find.
Attachment #417702 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 417702 [details] [diff] [review]
possible fix

Sorry, I kept hoping I'd manage to tell you what to do, not just what not to do, but

>+#folderLocationPopup > *:hover {

The English translation of that selector is "every single time that any element anywhere that mailWindow1.css is applied goes into the :hover state, stop, walk up the DOM to its parent element, and look up the id of its parent element to see if it's folderLocationPopup, whether or not (and since it requires customization, and is only really useful if you want to hide the folderpane because you loved that in NS4.x, in 99.9% of the cases that's going to be not) there is any element anywhere in the entire DOM with that id.

Too expensive, we need something that is at least only as horribly, grotesquely expensive as http://mxr.mozilla.org/comm-central/source/mail/themes/qute/mail/folderMenus.css#138 (or, for major massive bonus points, fix this and that both at once, so we don't have either one doing things that https://developer.mozilla.org/en/CSS/Writing_Efficient_CSS says multiple times are absolutely prohibited).
Attachment #417702 - Flags: review?(philringnalda) → review-
This also make the folder selector widget look consistent with itself.
Comment on attachment 437313 [details] [diff] [review]
updated patch that is less evil

Lets see if this works better.
Attachment #437313 - Flags: ui-review+
Attachment #437313 - Flags: review?(philringnalda)
Whiteboard: [needs review clarkbw,philor] → [needs review philor]
I think given where we are, this is a wanted improvement for Thunderbird.
Group: mozilla-confidential
blocking-thunderbird3.0: needed → ---
i'm pretty sure mark didn't intend to mark it confidential
Group: mozilla-confidential
Comment on attachment 437313 [details] [diff] [review]
updated patch that is less evil

Apparently I'm never going to get around to rooting out all evil, so lesser evil is probably a good idea.
Attachment #437313 - Flags: review?(philringnalda) → review+
Keywords: checkin-needed
Whiteboard: [needs review philor]
Checked in: http://hg.mozilla.org/comm-central/rev/6e93b14fc929
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1
You need to log in before you can comment on or make changes to this bug.