Unsent mail is not automatically sent when coming back online via network detection

RESOLVED FIXED in Thunderbird 3.0rc1

Status

Thunderbird
General
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Brad Rupp, Assigned: Bienvenu)

Tracking

({dataloss})

Thunderbird 3.0rc1
dataloss
Bug Flags:
blocking-thunderbird3 -

Firefox Tracking Flags

(blocking-thunderbird3.1 rc1+, thunderbird3.1 rc1-fixed, thunderbird3.0 wanted)

Details

(Whiteboard: [has reviewed patch])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091121 Thunderbird/3.0 (Thunderbird 3.0 RC1)

The new offline mode with IMAP is awesome for laptop users.  When I unplug my laptop from the network, messages are automatically scheduled to be sent later.  The problem is that when I plug the laptop back into the network the message is not automatically sent.  I still have to manually tell TB to send the message.

If the Offline settings dialog (Tools menu | Options | Advanced | Network & Disk Space tab | Offline), "send unsent messages when going online?" is set to "Yes."


Reproducible: Always

Steps to Reproduce:
1. Unplug from the network
2. Compose and e-mail and hit Send later
3. Plug into the network
Actual Results:  
The message is not automatically sent.

Expected Results:  
The message should be automatically sent.
If you come manually back online then it does work (or you get a prompt as per the preference setting).

If your laptop does automatic detection, then it won't automatically send (or prompt).

Automatic detection is present on Mac & Windows so setting os to all as that's the best match.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Hardware: x86 → All
Summary: Unsent mail is not automatically sent → Unsent mail is not automatically sent when coming back online via network detection
Version: unspecified → 3.0
Flags: blocking-thunderbird3?
We're not going to block on this, but we'll consider a fix if there is something that can be safely included in a security release.

Rafael: we should relnote this.
status-thunderbird3.0: --- → wanted
Flags: blocking-thunderbird3? → blocking-thunderbird3-
Keywords: relnote
this would be good to fix for the 3.1 time frame. I want to mark this blocking the 3.1 release but I'd rather get a fix in the 3.0.1 release.
if I were "with the times" I would have known about the proper flag setting to target this for the right release
Flags: blocking-thunderbird3.1+

Updated

8 years ago
blocking-thunderbird3.1: --- → needed
Flags: blocking-thunderbird3.1+
I think this is effectively dataloss, since users feel like they've sent something, but it doesn't actually arrive until some indefinite point in the future.
blocking-thunderbird3.1: needed → rc1+
Keywords: dataloss

Comment 6

8 years ago
(In reply to comment #5)
> I think this is effectively dataloss, since users feel like they've sent

For me it was much worse: after being offline, thunderbird started to complain that the "sent" folder could not be found, and it stopped working (could not get new messages, and could not successfully send new messages (could not find the "sent" folder anymore, an IMAP remote folder). Therefore I had to remove the config folder and reinstall.
Leandro: it's not clear to me why you believe the behavior you describe in comment 6 is part of this bug.  Can you elaborate?

Comment 8

8 years ago
(In reply to comment #7)
> Leandro: it's not clear to me why you believe the behavior you describe in
> comment 6 is part of this bug.  Can you elaborate?

Well, after being offline and composing a few messages, when I reconnected, thunderbird got stuck trying to send every message send during off-line mode, probably trying to open the "sent" mailbox (that was the error message). I had to restart thunderbird several times (once per each message composed in offline mode as it was waiting forever trying to copy the message just sent on the "sent" folder). After that, again in online mode, thunderbird could not work anymore (could not retrieve incoming messages, send new messages, etc. so I had to reinstall, cleanup the config, ...). So my taste of the off-line mode was quite a disaster.
I'm sorry to hear about that, it sounds like an unpleasant experience.  However, that sounds to me like it's probably not related to this specific bug.  I'd suggest looking in GetSatisfaction at <http://getsatisfaction.com/mozilla_messaging/topics/> to see if anyone else has encountered this issue, and, if not, opening a topic there.  Thanks!

Updated

7 years ago
Assignee: nobody → bugzilla
(Assignee)

Comment 10

7 years ago
I can look at this...
Assignee: bugzilla → bienvenu
Whiteboard: [investigating]
(Assignee)

Comment 11

7 years ago
Created attachment 443616 [details] [diff] [review]
do go online stuff when we've received the online notification

This patch moves the go online processing from the ui toggle to the "we've gone online" state change. This make us offer to send unsent messages, and playback offline operations when we autodetect that we've gone online.

For windows, I've only been able to trigger the autodetect by putting the machine to sleep and waking it up.

Magnus, please let me know if you won't be able to review this - it's a 3.1 rc1 blocker...thx!
Attachment #443616 - Flags: review?(mkmelin+mozilla)
(Assignee)

Updated

7 years ago
Whiteboard: [investigating] → [has patch for review mkmelin]

Comment 12

7 years ago
Comment on attachment 443616 [details] [diff] [review]
do go online stuff when we've received the online notification

Looks good to me
Attachment #443616 - Flags: review?(mkmelin+mozilla) → review+

Updated

7 years ago
Whiteboard: [has patch for review mkmelin] → [has reviewed patch]
Target Milestone: --- → Thunderbird 3.0rc1
(Assignee)

Comment 13

7 years ago
fixed for 3.1 rc1, landed on trunk and 1.9.2 comm-central branch
Status: NEW → RESOLVED
Last Resolved: 7 years ago
status-thunderbird3.1: --- → rc1-fixed
Resolution: --- → FIXED
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.