If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

js_FindDuplicateFormal misinterprets fun->u.i.names union

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: brendan, Assigned: jimb)

Tracking

({regression})

Trunk
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
See bug 514580 comment 11 et seq.

/be
(Reporter)

Updated

8 years ago
Keywords: regression
OS: Linux → All
Hardware: x86 → All
(Reporter)

Comment 1

8 years ago
Created attachment 415345 [details] [diff] [review]
with some trailing whitespace removal
Attachment #415345 - Flags: review?(jim)
(Reporter)

Comment 2

8 years ago
This strict formal checking looks costly -- under ES5's "use strict" or ye olde JSOPTION_STRICT, every function pays for CheckStrictForamls even though the code earlier in FunctionDef adds one formal at a time to fun->u.i.names and therefore knows right away whether there are any dups.

/be
(Assignee)

Updated

8 years ago
Attachment #415345 - Flags: review?(jim) → review+
(Reporter)

Comment 3

8 years ago
http://hg.mozilla.org/tracemonkey/rev/f8d3f3df9691

/be
Whiteboard: fixed-in-tracemonkey
(Assignee)

Comment 4

8 years ago
(In reply to comment #2)
> This strict formal checking looks costly -- under ES5's "use strict" or ye olde
> JSOPTION_STRICT, every function pays for CheckStrictForamls even though the
> code earlier in FunctionDef adds one formal at a time to fun->u.i.names and
> therefore knows right away whether there are any dups.

Filed as bug 532421.
(Assignee)

Comment 5

8 years ago
Test case added; patch and review in bug 532341.
Flags: in-testsuite+

Comment 6

8 years ago
http://hg.mozilla.org/mozilla-central/rev/872dcbf2c9c6
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 7

8 years ago
jimb: you missed a call to reportCompare. It will be automatically orange on jsreftests.
(Assignee)

Comment 8

8 years ago
(In reply to comment #7)
> jimb: you missed a call to reportCompare. It will be automatically orange on
> jsreftests.

http://hg.mozilla.org/tracemonkey/rev/860a58855453
Duplicate of this bug: 532436

Comment 10

8 years ago
http://hg.mozilla.org/mozilla-central/rev/f8d3f3df9691
You need to log in before you can comment on or make changes to this bug.