bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Alert Message (IMAP Connect Fail) Blocks Account Manager Windows

RESOLVED WORKSFORME

Status

Thunderbird
Account Manager
RESOLVED WORKSFORME
9 years ago
4 years ago

People

(Reporter: Jay Moran (jaym/lazvon), Unassigned)

Tracking

x86_64
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
TEST AND ACTUAL RESULTS:
While testing Bug 521653 I was adding a new account before IMAP had failed to connect to the server.

I heard the "Bong" audio alert for the window and my typing was interrupted on the account information dialog box filling in my Full Name.

No pop-up window was visible which should have said "Failed to connect to IMAP server imap.company.com" and the focus was lost on the Full Name field.

I clicked Cancel for the Account Info dialog box, which took me back to Account Manager.

I clicked the Cancel for Account Manager, nothing happened. Clicked OK, nothing happened.

Went to the Thunderbird Menu and clicked Quit, and that just closed the Account Manager box, didn't close all of Thunderbird though.

Went back into Account Manager, everything was working again.

EXPECTED RESULTS:
1) The Alert pop-up message would have been on top and I once I clicked OK to dismiss it, everything would have continued to function properly in the Account Manager setup dialog and Account Manager boxes.

2) Clicking QUIT in the Thunderbird menu would have quit the entire application, not just the Account Manager. In this case, it was probably fine, but wasn't what I was expecting.
(Reporter)

Comment 1

9 years ago
MacOSX 10.6.2 and Thunderbird 3.0RC3 (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091121 Thunderbird/3.0)
(Reporter)

Updated

9 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false

Comment 2

6 years ago
Pedro, doe sthis reproduce for you?
Flags: needinfo?(pedgarrod)

Comment 3

4 years ago
Mitra does this reproduce for you?
Flags: needinfo?(pedgarrod) → needinfo?(mitra_lists)

Comment 4

4 years ago
I'm unclear of the STR - if I go Tools -> Accounts -> Account Actions -> New then my name is the first thing it asks me, it doesn't know what host to connect to at that point

Jay - can you give us repeatable steps to repeat this ?
Flags: needinfo?(mitra_lists)
(Reporter)

Comment 5

4 years ago
Wow, five years... :)

Reading back over this, I do not remember the specifics. From other issues encountered since then I wonder if the pop-up alert dialog was off screen. Especially around that time, MacOSX had some issues with off screen alert dialogs being a problem and no way to "Gather Windows" like current versions of MacOSX.

That said, the fact that "Quit" ended up just closing the Account Manager window certainly sounds like a child process had gained some level of control as Quit from the main menu shouldn't have just quit that Account Manager window?

No matter what, since I cannot reproduce, I would go ahead and mark it UNREPRODUCIBLE... though that doesn't look like an option any longer (or I no longer have the Bugzilla access I used to have).

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.