Confusing (i.e. inconsistent) display, naming, and treatment of attachments

RESOLVED DUPLICATE of bug 436555

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 436555
8 years ago
8 years ago

People

(Reporter: Ulrich Windl, Unassigned)

Tracking

(Blocks: 1 bug)

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4) Gecko/20091017 SUSE/2.0.0-1.1.3 SeaMonkey/2.0
Build Identifier: 

Being new to Thunderbird, but not to E-Mail, I thing these things are very confusing:
For a MIME message with an attachment of type "message/delivery-status" that part is displayed inline with no special indication that this is an attachment (there is some special line above).
In the list of attachments, that part of the message is displayed as "Part 1.2" without any further explanations. When double-clicking on it, Thunderbird offers to save that part to disk, or open it with an application the user has to select. Note that Thunderbird does not offer to _display_ it with its own viewer. At this point the user has no idea what "Part 1.2" really contains.

A first improvement would be to display some tooltip-kind-of-help showing the type and size of the attachment when hovering with the mouse over it.

Also note that the behavior is inconsistent: For an attachmant of type "message/rfc822" Thunderbird detects that as EMail which can be displayed by double-clicking.

The next inconsistent thing is naming the attachments: The first attachment is named "Part 1.2" (well, "Where is Part 1.1?" the user might ask), while the second attachment is named "ForwardedMessage.eml", even though _both_ attachments have no name.

Therefore I'd suggest to
1) display all parts in a unique way, i.e. "Part 1.1", "Part 1.2", "Part 1.3", independent of which part is actually displayed
2) The parts information should include the MIME type (like "message/rfc822", "text/plain"), (if present) the encoding ("base64", "quoted-printable"), charset ("UTF-8", "US-ASCII", "iso8859-15"), and the size (in user-readable units like "2Kb" (not: "12637236")
3) When displaying one or more parts of a multipart MIME message, indicate which parts are being displayed.

As a MIME message can actually be a tree of attachments (not just a list), it might be a good idea to try to have some tree control for expand/collapse the individual parts of a message.

Reproducible: Always

Steps to Reproduce:
See description
Actual Results:  
The user doesn't like Thunderbird very much

Expected Results:  
The user should say "That's better than anything else"
(Reporter)

Updated

8 years ago
Version: unspecified → 2.0
Ulrich you will be able to get thunderbird 3.0 in a few hours can you check that the behavior did not change ?
(Reporter)

Comment 2

8 years ago
I just tried Thunderbird 3.0: No change; it's the same as Thunderbird 2
Version: 2.0 → 3.0

Updated

8 years ago
Blocks: 579473

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 436555
You need to log in before you can comment on or make changes to this bug.