[HTML5] <script> coming after </head> but not inside <body> doesn't run

RESOLVED DUPLICATE of bug 531373

Status

()

--
major
RESOLVED DUPLICATE of bug 531373
9 years ago
9 years ago

People

(Reporter: bzbarsky, Assigned: hsivonen)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 416263 [details]
Testcase

Testcase attached.  It should alert "hello".  Instead I get:

###!!! ASSERTION: Script wasn't marked as malformed.: 'sele->IsMalformed()', file ../../../mozilla/parser/html/nsHtml5TreeOpExecutor.cpp, line 364

and no script execution.

This breaks United.com's boarding pass printing page.  Which incidentally means that if you fix this in the next two weeks I can test the fix on my flight back... ;)
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 531373
You need to log in before you can comment on or make changes to this bug.