Closed Bug 533653 Opened 10 years ago Closed 10 years ago

hover pseudo-class cannot be bound to a class in css in HTML 4.01 Transitional

Categories

(Firefox :: General, defect)

3.5 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 197686

People

(Reporter: jp, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.30 Safari/532.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Mozilla fails to render hover states of classnames in css.

Reproducible: Always

Steps to Reproduce:
1. create a page in HTML 4.01 Transitional
2. define a class with a hover state
Actual Results:  
Hover state doesn't activate

Expected Results:  
Hover state should activate

See the blog post for a working example of problem code: http://jpgrace.com/blog/2009/12/firefox-bug-hover-cannot-bind-to-a-classname-with-css-in-html-4-01-transitional/
I've tested this in multiple versions of FF and on both Mac and PC.  All versions of the Firefox browser exhibit this bug.
Version: unspecified → 3.5 Branch
html 4.01 transitional without full url triggers quirks mode
http://hsivonen.iki.fi/doctype/#handling

In that case it is a known behavior:
https://developer.mozilla.org/en/Mozilla%27s_Quirks_Mode
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501281
You need to log in before you can comment on or make changes to this bug.