Last Comment Bug 197686 - :hover (dynamic pseudo-class) doesn't work after class selectors with no tag name in quirks mode
: :hover (dynamic pseudo-class) doesn't work after class selectors with no tag ...
Status: VERIFIED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: P4 major with 1 vote (vote)
: mozilla6
Assigned To: David Baron :dbaron: ⌚️UTC-8
:
: Jet Villegas (:jet)
Mentors:
http://mithgol.pp.ru/Mozilla/hoverbug...
: 219853 232757 244065 297950 501281 533653 586031 595476 635654 667964 (view as bug list)
Depends on: 945607
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-16 06:53 PST by Sergey «Mithgol the Webmaster» Sokoloff
Modified: 2013-12-03 00:39 PST (History)
18 users (show)
djcater+bugzilla: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.44 KB, patch)
2011-04-22 17:18 PDT, David Baron :dbaron: ⌚️UTC-8
bzbarsky: review+
Details | Diff | Splinter Review

Description Sergey «Mithgol the Webmaster» Sokoloff 2003-03-16 06:53:46 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

After upgrading to Mozilla 1.3, I've seen major CSS2 functionality loss. :hover
(dynamic pseudo-class) doesn't work after universal class selectors
(.classname:hover), where it worked in Mozilla 1.2.1. Still it works in
TAGNAME:hover (see http://mithgol.pp.ru/Mozilla/hoverbug.htm for test case).

All that makes me greatly upset. Probably we'll need Mozilla 1.3.1 really soon,
since several CSS2 menus are lost. Imagine .classname:hover { visiblity: ... };

Reproducible: Always

Steps to Reproduce:
1. Enter http://mithgol.pp.ru/Mozilla/hoverbug.htm in location field.
2. Load the page, follow the instructions.
3. Note that Mozilla 1.3 and 1.2.1 behave differetly.

Actual Results:  
Class .test:hover (see page source) doesn't work in Mozilla 1.3. A major feature
is broken; I'll set bug priority to Major.

Expected Results:  
Class .test:hover should work as in Mozilla 1.2.1, according to W3C
specification docs.

Tested under Win2000 and Win98, the same results.

I'm not completely sure that component is "Style System"; check it for yourself
also.
Comment 1 David Baron :dbaron: ⌚️UTC-8 2003-03-16 07:09:29 PST
This was done intentionally, but in quirks mode only.  See bug 169078.  (It was
done because allowing this breaks a bunch of web pages that expect :hover to
apply only to links.)

If your page has a doctype that puts the browser into standards mode (see
http://mozilla.org/docs/web-developer/quirks/ ), then you won't have to deal
with these quirks.
Comment 2 Sergey «Mithgol the Webmaster» Sokoloff 2003-03-16 08:31:05 PST
Hmm...

You could at least mention it in your quirklist at
http://mozilla.org/docs/web-developer/quirks/quirklist.html - it's "Last
modified August 20, 2002", that's really old.

Your advice sounds really funny, my documents never validate under strict
validators, that's why I never used any !DOCTYPE, so what am I forced to do with
this quirk? To invent my own doctype?
Comment 3 David Baron :dbaron: ⌚️UTC-8 2003-03-16 09:44:28 PST
You could just add "<!DOCTYPE html>"
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2003-03-16 20:27:09 PST
Verified.  If your page is tag soup, it gets treated as tag soup (and you can
validate to Transitional and still have a doctype, you know...)
Comment 5 Logan Ingalls 2004-05-19 09:44:20 PDT
*** Bug 244065 has been marked as a duplicate of this bug. ***
Comment 6 David Baron :dbaron: ⌚️UTC-8 2005-06-16 18:25:13 PDT
*** Bug 297950 has been marked as a duplicate of this bug. ***
Comment 7 David Baron :dbaron: ⌚️UTC-8 2009-12-09 09:27:17 PST
*** Bug 219853 has been marked as a duplicate of this bug. ***
Comment 8 David Baron :dbaron: ⌚️UTC-8 2009-12-09 09:27:37 PST
*** Bug 232757 has been marked as a duplicate of this bug. ***
Comment 9 David Baron :dbaron: ⌚️UTC-8 2009-12-09 09:28:22 PST
*** Bug 501281 has been marked as a duplicate of this bug. ***
Comment 10 David Baron :dbaron: ⌚️UTC-8 2009-12-09 09:28:34 PST
*** Bug 533653 has been marked as a duplicate of this bug. ***
Comment 11 David Baron :dbaron: ⌚️UTC-8 2009-12-09 09:34:03 PST
Bug 501281 comment 6 says:
> > This is a known quirks mode behavior:
> > https://developer.mozilla.org/en/Mozilla%27s_Quirks_Mode
> > 
> > Is it not present in other browsers anymore?
>
> Opera 10b and WebKit/Safari4 do not have this Quirk (anymore). IE 8 mimics IE6
> & 7 (and Gecko) in quirks mode.
Comment 12 Boris Zbarsky [:bz] (still a bit busy) 2010-08-10 21:43:55 PDT
*** Bug 586031 has been marked as a duplicate of this bug. ***
Comment 13 David Baron :dbaron: ⌚️UTC-8 2010-09-12 12:34:09 PDT
I think we can probably remove this quirk; WebKit doesn't have it.  (Or do they have a different variation of it?)
Comment 14 David Baron :dbaron: ⌚️UTC-8 2010-09-12 12:35:50 PDT
*** Bug 595476 has been marked as a duplicate of this bug. ***
Comment 15 David Baron :dbaron: ⌚️UTC-8 2011-02-20 22:46:18 PST
*** Bug 635654 has been marked as a duplicate of this bug. ***
Comment 16 David Baron :dbaron: ⌚️UTC-8 2011-04-22 17:18:02 PDT
Created attachment 527890 [details] [diff] [review]
patch
Comment 17 Boris Zbarsky [:bz] (still a bit busy) 2011-04-22 17:44:52 PDT
Comment on attachment 527890 [details] [diff] [review]
patch

r=me
Comment 18 David Baron :dbaron: ⌚️UTC-8 2011-04-22 19:18:50 PDT
https://hg.mozilla.org/mozilla-central/rev/b7b5af018848
Comment 20 Eric Shepherd [:sheppy] 2011-04-24 18:46:56 PDT
I cleaned up the edit here:

https://developer.mozilla.org/en/Mozilla_Quirks_Mode_Behavior

And added a note on Firefox 6 for developers. Thanks!
Comment 21 j.j. 2011-06-28 16:52:04 PDT
*** Bug 667964 has been marked as a duplicate of this bug. ***
Comment 22 Simona B [:simonab ] 2011-07-19 07:57:58 PDT
Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110719 Firefox/8.0a1

Verified issue on Win XP, Win 7, Ubuntu 11.04 and Mac OS x 10.6 - using the test case from Bug 635654 that was marked as a duplicate of this one (Bug 197686). 

Setting resolution to VERIFIED FIXED.

Note You need to log in before you can comment on or make changes to this bug.