Last Comment Bug 533691 - Violation of Microsoft's copyright in IENUMFE.CPP / IENUMFE.H?
: Violation of Microsoft's copyright in IENUMFE.CPP / IENUMFE.H?
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86 Windows 2000
: -- normal (vote)
: mozilla1.9.3a1
Assigned To: Jim Mathies [:jimm]
:
: Jim Mathies [:jimm]
Mentors:
http://bonsai.mozilla.org/cvsview2.cg...
Depends on: 537414
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-09 04:28 PST by martin.feger
Modified: 2010-03-11 17:52 PST (History)
8 users (show)
mbeltzner: blocking1.9.2+
mbeltzner: blocking1.9.0.19-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
alpha1+
final-fixed
.9+
.9-fixed


Attachments
revamp v.1 (19.38 KB, patch)
2009-12-17 14:31 PST, Jim Mathies [:jimm]
no flags Details | Diff | Splinter Review
License original code is provided under (978.43 KB, image/jpeg)
2009-12-17 16:40 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
no flags Details
revamp v.2 (19.82 KB, patch)
2009-12-18 14:38 PST, Jim Mathies [:jimm]
roc: review+
Details | Diff | Splinter Review
Rollup for 1.9.1 (19.79 KB, patch)
2010-01-26 16:26 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
roc: review+
dveditz: approval1.9.1.9+
Details | Diff | Splinter Review
Patch for 1.9.0 (20.23 KB, patch)
2010-02-13 18:40 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
roc: review+
mbeltzner: approval1.9.0.19-
Details | Diff | Splinter Review

Description martin.feger 2009-12-09 04:28:11 PST
User-Agent:       Agent 99
Build Identifier: 

See the URL. For comparison, the current version has not changed much:
http://mxr.mozilla.org/mozilla-central/source/widget/src/windows/IEnumFE.cpp

Can somebody explain this change? Did Netscape really get Microsoft's permission to make this change, back in 1999, when these two companies were not exactly best buddies? It seems unlikely that MS would allow anybody to just take their sample code and claim to be the initial developer.

Reproducible: Always
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2009-12-09 15:52:11 PST
From the author's bio (http://www.kraigbrockschmidt.com/about.htm)

" In late 1991 he took a position in Microsoft’s technical evangelism group, Developer Relations, where he remained for the bulk of his career.

In Developer Relations, Kraig used his skills to speed the adoption of Microsoft’s newest technologies by other software companies. He offered papers and sample programs that demonstrated exactly how to incorporate those technologies into a wide variety of applications and regularly spoke at industry conferences. In addition, he continued to publish articles in magazines such as Microsoft Systems Journal and Windows Programming Journal."
Comment 2 Gervase Markham [:gerv] 2009-12-10 13:37:42 PST
Martin: thanks for bringing this to our attention.

roc is the module owner for Widget. roc: is this code still used?

Gerv
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2009-12-10 13:39:28 PST
I can confirm that the code is still used.  It's integral to the implementation of nsDataObj
Comment 4 Robert O'Callahan (:roc) (email my personal email if necessary) 2009-12-10 16:56:59 PST
Ugh. Jim, can you rewrite this code? It's not much code at least.
Comment 5 Jim Mathies [:jimm] 2009-12-12 08:26:23 PST
(In reply to comment #4)
> Ugh. Jim, can you rewrite this code? It's not much code at least.

Sure, I've got another bug related to sample code submission I need to clean up as well. Will get to this next week.
Comment 6 Jim Mathies [:jimm] 2009-12-17 14:31:44 PST
Created attachment 418270 [details] [diff] [review]
revamp v.1

First rev, going to throw this at try.
Comment 7 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2009-12-17 16:40:58 PST
Created attachment 418300 [details]
License original code is provided under

For what little it's worth, the code is sample code provided with Inside OLE 2, which I was able to borrow a copy of.  I've attached the license agreement.  Amusingly enough, it's actually really permissive.  Really the only part that's problematic is the agreement to "include the copyright notice ... on your product label and as a part of the sign-on message for your software product."
Comment 8 Jim Mathies [:jimm] 2009-12-17 16:53:02 PST
(In reply to comment #7)
> Created an attachment (id=418300) [details]
> License original code is provided under
> 
> For what little it's worth, the code is sample code provided with Inside OLE 2,
> which I was able to borrow a copy of.  I've attached the license agreement. 
> Amusingly enough, it's actually really permissive.  Really the only part that's
> problematic is the agreement to "include the copyright notice ... on your
> product label and as a part of the sign-on message for your software product."

Probably not something we'll want to do. :) Regardless, that code had shortcomings, it needed to be replaced.
Comment 9 Jim Mathies [:jimm] 2009-12-18 14:38:02 PST
Created attachment 418432 [details] [diff] [review]
revamp v.2
Comment 10 Jim Mathies [:jimm] 2009-12-18 14:38:47 PST
The diff is pretty ugly, it's simpler to just apply the patch and look at the source.
Comment 11 Robert O'Callahan (:roc) (email my personal email if necessary) 2009-12-18 21:09:22 PST
Comment on attachment 418432 [details] [diff] [review]
revamp v.2

+  PRInt32 count = static_cast<PRInt32>(aMaxToFetch) < left ? static_cast<PRInt32>(aMaxToFetch) : left;

NS_MIN?

+    memset(&mFormat, 0, sizeof(FORMATETC));
+    if (!aSrc)
+        return;

Put the memset inside the if?
Comment 12 Jim Mathies [:jimm] 2009-12-20 09:04:43 PST
http://hg.mozilla.org/mozilla-central/rev/34386757d749
Comment 13 Mike Beltzner [:beltzner, not reading bugmail] 2009-12-23 10:07:35 PST
Any reason why this hasn't landed on 1.9.2 yet?
Comment 14 :Gavin Sharp [email: gavin@gavinsharp.com] 2009-12-23 11:50:36 PST
Looked into landing this on 1.9.2, but it looks like bug 528731 has already landed there, in the opposite order that it did on trunk, so the patch doesn't apply.
Comment 15 Jim Mathies [:jimm] 2009-12-27 09:30:46 PST
(In reply to comment #13)
> Any reason why this hasn't landed on 1.9.2 yet?

Sorry, this got blocking status on tuesday which I missed before my break. Will be landing it today.
Comment 17 Jim Mathies [:jimm] 2010-01-10 12:12:31 PST
note to self - idx bug patch should be included in future landings of this on branch.
Comment 18 Daniel Veditz [:dveditz] 2010-01-12 10:56:56 PST
When you create the branch-merged patches please include the fix for regression bug 537414 as a combined patch for the approval request.
Comment 19 David Baron :dbaron: ⌚️UTC-10 2010-01-22 14:30:22 PST
Marking the 14 bugs that are both:
 * nominated for blocking1.9.3:?
 * fixed on the 1.9.2 branch (according to status1.9.2)
as blocking1.9.3:alpha1, so that we don't have to go through the nominations individually.  They're all fixed already (so there's no work to do), and being fixed on 1.9.2 means they probably do block 1.9.3.
Comment 20 Mike Beltzner [:beltzner, not reading bugmail] 2010-01-26 10:47:02 PST
Jim, can you get someone to help you with a roll-up branch patch here? Drivers will approve when it's ready.
Comment 21 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-01-26 10:53:28 PST
(In reply to comment #20)
> Jim, can you get someone to help you with a roll-up branch patch here? Drivers
> will approve when it's ready.

I'm willing to do that, but Bug 538891 still needs approval for 1.9.2
Comment 22 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-01-26 16:26:22 PST
Created attachment 423692 [details] [diff] [review]
Rollup for 1.9.1

This includes

http://hg.mozilla.org/mozilla-central/rev/34386757d749
http://hg.mozilla.org/mozilla-central/rev/6c1cd8a81f95
http://hg.mozilla.org/mozilla-central/rev/f5fca857c581

I'm going to throw this at try to have it run my DnD tests against it.
Comment 23 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-02-01 19:59:22 PST
Comment on attachment 423692 [details] [diff] [review]
Rollup for 1.9.1

I abandoned my attempt to get the DnD tests ported to 1.9.1, the linkage has changed too much to make it worth it IMO.

Nevertheless, the patch just the others combined, there was hardly any merge fuzz and nothing substantive.
Comment 24 Mike Beltzner [:beltzner, not reading bugmail] 2010-02-10 12:44:43 PST
Who can review the patch?
Comment 25 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-02-10 13:26:09 PST
(In reply to comment #24)
> Who can review the patch?

The differences from the three patches it came from are trivial, but if it does need review I'd suggest roc :-)
Comment 26 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-02-10 14:31:40 PST
I'll try to get to the 1.9.0 patch this weekend.
Comment 27 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-02-13 18:40:22 PST
Created attachment 426868 [details] [diff] [review]
Patch for 1.9.0

Rolled up patch for 1.9.0.  There are no real differences between this and the 1.9.1 patch.
Comment 28 Robert O'Callahan (:roc) (email my personal email if necessary) 2010-02-14 13:19:30 PST
Comment on attachment 426868 [details] [diff] [review]
Patch for 1.9.0

Thanks a ton!
Comment 29 Daniel Veditz [:dveditz] 2010-02-19 13:59:41 PST
Comment on attachment 423692 [details] [diff] [review]
Rollup for 1.9.1

Approved for 1.9.1.9, a=dveditz for release-drivers
Comment 30 Daniel Veditz [:dveditz] 2010-02-19 14:00:02 PST
Comment on attachment 426868 [details] [diff] [review]
Patch for 1.9.0

Approved for 1.9.0.19, a=dveditz for release-drivers
Comment 31 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-02-19 15:08:56 PST
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/5b43afb4c5dc
Comment 32 Mike Beltzner [:beltzner, not reading bugmail] 2010-03-10 12:55:47 PST
Comment on attachment 426868 [details] [diff] [review]
Patch for 1.9.0

This missed the boat, and now the branch is going to be unsupported, so I'm finding it hard to get worked up about this.
Comment 33 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-03-11 17:52:18 PST
(In reply to comment #32)
> (From update of attachment 426868 [details] [diff] [review])
> This missed the boat, and now the branch is going to be unsupported, so I'm
> finding it hard to get worked up about this.

Woops I meant to find someone to check this into CVS, totally slipped my mind.  I also have a hard time caring about it now that the branch is over.

Note You need to log in before you can comment on or make changes to this bug.