Last Comment Bug 538891 - Overflow at CEnumFormatEtc::Next
: Overflow at CEnumFormatEtc::Next
Status: RESOLVED FIXED
: regression, verified1.9.2
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
: Jim Mathies [:jimm]
Mentors:
Depends on:
Blocks: 537414
  Show dependency treegraph
 
Reported: 2010-01-10 12:32 PST by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2010-03-22 13:51 PDT (History)
4 users (show)
mbeltzner: blocking1.9.0.19-
dveditz: wanted1.9.0.x+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.2+
.2-fixed
.9+
.9-fixed


Attachments
Patch (845 bytes, patch)
2010-01-10 12:32 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
jmathies: review+
mbeltzner: approval1.9.2.2+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-01-10 12:32:05 PST
Created attachment 420975 [details] [diff] [review]
Patch

https://bugzilla.mozilla.org/show_bug.cgi?id=537414#c7
Comment 1 Jim Mathies [:jimm] 2010-01-10 15:59:35 PST
Comment on attachment 420975 [details] [diff] [review]
Patch

+ PRUint32 count = NS_MIN(static_cast<PRUint32>(aMaxToFetch), left);

Do we need that static cast anymore?
Comment 2 Jim Mathies [:jimm] 2010-01-10 16:33:02 PST
http://hg.mozilla.org/mozilla-central/rev/f5fca857c581
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-01-19 07:00:21 PST
Comment on attachment 420975 [details] [diff] [review]
Patch

We haven't seen any actual regressions from this yet (it's more of a theoretical bug than anything) but it's an easy fix so we may want to consider taking it on branch.
Comment 4 Daniel Veditz [:dveditz] 2010-02-02 07:59:37 PST
nominated for older branches because it fixes a regression from bug 533691
Comment 5 Mike Beltzner [:beltzner, not reading bugmail] 2010-02-24 12:42:09 PST
Comment on attachment 420975 [details] [diff] [review]
Patch

a1922=beltzner
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-03-01 15:26:16 PST
Landed on 1.9.2 as http://hg.mozilla.org/releases/mozilla-1.9.2/rev/263ee4ee7da2

Landed on 1.9.1 in the rollup.
Comment 7 Tracy Walker [:tracy] 2010-03-22 13:43:03 PDT
I don't know what to test here. verified per check-in and verification of 533691
Comment 8 Jim Mathies [:jimm] 2010-03-22 13:51:13 PDT
(In reply to comment #7)
> I don't know what to test here. verified per check-in and verification of
> 533691

Nothing really to test, this was just a bug fix patch for some code that landed.

Note You need to log in before you can comment on or make changes to this bug.