HTML attachments cannot be opened because recognized as "mailbox" or "imap" file type

RESOLVED DUPLICATE of bug 533462

Status

Thunderbird
Message Reader UI
--
major
RESOLVED DUPLICATE of bug 533462
8 years ago
7 years ago

People

(Reporter: u167265, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

HTML files attached to email messages cannot be opened in Thunderbird 3 on Windows Vista, because Thunderbird thinks they are of the "mailbox" (in local folders) or "imap" (IMAP folers) file type. When firefox.exe is selected as (default) application for opening "mailbox" or "imap" files, Firefox says that it doesn't know the "mailbox" or "imap" protocol.

Reproducible: Always

Steps to Reproduce:
1. Compose a new email message
2. Attach an HTML file
3. Save the message as draft
4. Open the draft and open the attachment (double-click, or right-click and select Open)
Actual Results:  
The pop-up window "Launch Application" is opened. When an application is chosen (e.g. Firefox), it says that it can't handle the protocol.

Expected Results:  
The pop-up window "Launch Application" is opened. When an application is chosen (e.g. Firefox), it displays the file in the browser.

This problem occurs with messages created in Thunderbird itself as well as with downloaded messages generated by other email clients.

This problem occurs in my existing Thunderbird installation and profile (upgraded from version 2) as wel as in a fresh installation of Thunderbird 3.0 final with a newly created profile.

Windows Vista is configured to open HTML files in Firefox (in Configuration Panel, Default Programs, Set your default programs).
(Reporter)

Comment 1

8 years ago
Created attachment 416901 [details]
Launch Application pop-up window when an attached HTML file is opened
status-thunderbird3.0: --- → ?
Keywords: qawanted
(Reporter)

Comment 2

8 years ago
Note: these problems didn't occur in Thunderbird 2.
WFM on MacOS
WFM on Windows I did test with IE8 not Firefox.

Can you try in -safe-mode (http://kb.mozillazine.org/Safe_mode)?
Keywords: qawanted

Comment 4

8 years ago
I have this problem as well. It occurs with the digest version of an email list, formatted as HTML. I did not have this problem with Thunderbird 2. Using Windows XP.

Comment 5

8 years ago
I tried it in Safe Mode and had the same result.
Dup of bug 533462?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
status-thunderbird3.0: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 533462
You need to log in before you can comment on or make changes to this bug.