Thunderbird crashes when I paste a JabRef citation into the Composer

RESOLVED DUPLICATE of bug 495392

Status

Thunderbird
Message Compose Window
--
critical
RESOLVED DUPLICATE of bug 495392
8 years ago
7 years ago

People

(Reporter: Sebastian Späth, Unassigned)

Tracking

({crash, stackwanted})

x86_64
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
1) Install JabRef and copy a citation with Ctrl-C from the summary view of a citation in the lower half of the window.

2) Paste with CTRL-C into a new (non-html) mail composition text body window

3) kaboom. Crash. 100% reproducable both with TB2 and TB3. It does not seem to depend on the citation you've chosen either. It crashes with all of them.

P.S. If I copy into gedit first and then into TB, everything is fine.
Matej isn't that a dup of the bug one of your collegue is working on ?

Comment 2

8 years ago
need crash keywd

Updated

8 years ago
Keywords: crash

Updated

8 years ago
Keywords: stackwanted

Updated

8 years ago
(Reporter)

Comment 3

8 years ago
Doh, with current 3.0.2pre and Jabref 2.5 I cannot reproduce the crash anymore. This bug which has bugged me for 2 years seems to be gone.

Marking as resolved. I will reopen with a stacktrace if it occurs again.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

8 years ago
I probably spoke too soon. I see that Ubuntu seems to have fixed this somehow:

https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/408920
"Today a fix has been provided via 'karmic-proposed'."

However, as I have no idea whether this fix has gone upstream, I'll leave this open. I am not able to reproduce that with my standard Ubuntu install anymore, however.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Can you attach the ubuntu patch here?
(Reporter)

Comment 6

8 years ago
Unfortunately not, as I don't know which patch has been applied or what has been done to fix this. A comment to the  ubuntu bug has been added, asking for details (it seems the person stating that "a bug fix has been provided" is not even an ubuntu person. I will update this bug if I an reproduce the bug (hopefully getting a stack trace), or if details in the ubuntu bug emerge. I feel a little dumb now that I cannot reproduce this long-standing bug anymore, I have to admit :-)

Comment 7

7 years ago
according to https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/372103 it sounds like this should be fixed in bug 495392
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
OS: Linux → Windows CE
Resolution: --- → DUPLICATE
Duplicate of bug: 495392

Updated

7 years ago
OS: Windows CE → Linux
You need to log in before you can comment on or make changes to this bug.