Closed Bug 534152 Opened 13 years ago Closed 10 years ago

Handle collapsed navbar better

Categories

(Firefox :: Theme, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Firefox 3.7a1

People

(Reporter: mstange, Assigned: mstange)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch v2 (obsolete) — Splinter Review
Follow-up to bug 461291 -
In the main browser window, when the bookmarks bar is hidden, the tab bar overlays the bottom separator line of the navbar. However, if the navbar is hidden (either through View -> Toolbars -> uncheck Navigation Toolbar or through the toolbar collapse pill button), the tab bar should ideally overlay the bottom separator line of the *title* bar.
However, we don't really want to draw in the titlebar. But instead of hiding the navbar completely, we can just keep it visible and make it only 2px high. Then the lower pixel row is overlaid by the tab bar, and the upper pixel row is visible.
Having at least a part of a "unified toolbar" visible is necessary since the titlebar gradient is only corrected by the widget code whenever such a toolbar is drawn.
Attachment #417061 - Flags: review?(dao)
Depends on: 534154
Attachment #417061 - Flags: review?(dao) → review-
Comment on attachment 417061 [details] [diff] [review]
v2

I think this is too hacky, especially the dependency on bug 534154. There should be better ways to achieve this. Here's one idea that came to my mind:

>#main-window[chromehidden~="toolbar"][chromehidden~="location"][chromehidden~="directories"]::before {
>  content: "";
>  display: -moz-box;
>  -moz-appearance: -moz-mac-unified-toolbar;
>  height: 2px;
>}
That's a great idea!
Attached patch v3Splinter Review
Yeah, this is good enough.
Attachment #417061 - Attachment is obsolete: true
Attachment #421099 - Flags: review?(dao)
Attachment #421099 - Flags: review?(dao) → review+
http://hg.mozilla.org/mozilla-central/rev/28e8bdda3413
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
Backed out:
http://hg.mozilla.org/mozilla-central/rev/0be25aef273f
http://hg.mozilla.org/mozilla-central/rev/739d8699dce6

This regressed SunSpider and DHTML Talos numbers, see bug 461291 comment 12. Both of these tests run in a window with collapsed toolbars, so the selector in this patch matches.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
So I bet any style reresolve on the window reframes it with that selector, because the relevant part of the frametree is:

    DocElementBox(window)(-1)@0x137d550 {0,0,36600,22920} [state=81a40010] [content=0x1ee2bd10] [sc=0x137d4f8]<
      PopupSet(popupgroup)(-1)@0x138b488 next=0x138b6b8 {0,0,36600,0} [state=80c40000] [content=0x1ee327e0] [sc=0x137d6a0]<
        Popup-list for PopupSet(popupgroup)(-1)@0x138b488 <
          MenuPopup(tooltip)(-1)@0x138b500 [view=0x1ee336d0] {0,0,0,0} [state=80802502] [content=0x1ee32820] [sc=0x137d988]<>
        >
      >
      Placeholder(tooltip)(-1)@0x138b6b8 {0,0,36600,0} [state=00800000] [content=0x1ee32820] outOfFlowFrame=MenuPopup(tooltip)(-1)@0x138b500
      Box(_moz_generated_content_before)(-1)@0x138b6f0 {0,0,36600,120} [state=a0c00040] [content=0x1ee33560] [sc=0x137d828] pst=:before<

so GetFirstChildFrame doesn't find the ::before content.
I see the tooltip and its placeholder in the same place on Linux, but I can't figure out the theme code enough to be able to get some before generated content (either there, or in the right place).
Duplicate of this bug: 583236
This was a style tweak for windows without a navigation toolbar and with tabs-on-bottom. I don't think that configuration is worth worrying about anymore.
Status: REOPENED → RESOLVED
Closed: 13 years ago10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.