Last Comment Bug 534449 - Gloda should index sent messages right away instead of waiting for me to open the sent folder. Message missing from conversation view
: Gloda should index sent messages right away instead of waiting for me to open...
Status: RESOLVED FIXED
[gloda key]
:
Product: MailNews Core
Classification: Components
Component: Database (show other bugs)
: Trunk
: All All
: -- enhancement with 3 votes (vote)
: Thunderbird 5.0b1
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 537019 540207 640553 (view as bug list)
Depends on: 562115 574441 646226
Blocks: 523939 glodafailtracker
  Show dependency treegraph
 
Reported: 2009-12-12 14:20 PST by Jonathan Protzenko [:protz]
Modified: 2011-05-07 01:39 PDT (History)
13 users (show)
dmose: wanted‑thunderbird+
bugmail: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
-


Attachments
v1 utilize the new msgKeyChanged notification (38.88 KB, patch)
2011-01-15 12:46 PST, Andrew Sutherland [:asuth]
mozilla: review+
Details | Diff | Splinter Review

Description Jonathan Protzenko [:protz] 2009-12-12 14:20:12 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

Sent messages take a lot of time to be indexed. They are indexed :
- either if I restart Thunderbird,
- or if I open the "Sent" folder.

Although I have "Check this folder for new messages" checked for my sent folder, and imap.check_all_folders_for_new set to true, the messages don't get downloaded, and indexed, until I open the sent folder.

This is quite annoying since they don't show up in search results. I'm designing an extension that allows you to see your own messages in threads (see https://addons.mozilla.org/en-US/thunderbird/addon/54035) and it's quite confusing to open up a thread and not find your own messages until you go look for them in the "Sent" folder.

Reproducible: Always
Comment 1 Andrew Sutherland [:asuth] 2009-12-14 16:51:41 PST
Yeah, I'm seeing this too.  I suspect we aren't generating the required notification for gloda to know about newly sent messages.
Comment 2 Ludovic Hirlimann [:Usul] 2010-01-05 05:45:00 PST
*** Bug 537019 has been marked as a duplicate of this bug. ***
Comment 3 Andrew Sutherland [:asuth] 2010-01-16 16:23:13 PST
*** Bug 540207 has been marked as a duplicate of this bug. ***
Comment 4 Dan Mosedale (:dmose) 2010-03-03 18:58:37 PST
We're resetting the blocking flag for 3.1 on this bug and instead setting the wanted-thunderbird+ flag. We have too many blocking-3.1 bugs, to the point where it doesn't mean much, and managing the list is making it hard to actually work on closing bugs, which helps no one.

Thunderbird 3.1's primary purpose is to allow us to offer a prompted major update to Thunderbird 2 users, to ensure their continued ability to safely use Thunderbird.  Thunderbird 2 is built on an outdated version of Gecko, and our long-term ability to maintain the users' safety for Thunderbird 2 users is limited.

If you think this bug meets the requirements below, please renominate with a detailed explanation of how it meets the following two criteria, and we will reconsider.  To qualify, this bug must either:

a) make the upgrade experience from TB2 very painful for a large number of users

or

b) be a new, reproducible, severe quality issue (eg dataloss, frequent crashes)

Just because this bug doesn't block TB3.1 doesn't mean it can't or won't make the release.  Once they're done with their blockers (if any), we encourage developers to keep working on non-blocking bugs, and to try to land them as early in the cycle as possible, as non-blocking bugs will become increasingly difficult to land in the later stages of the cycle.
Comment 5 Andrew Sutherland [:asuth] 2010-03-29 10:04:45 PDT
sid0 or bienvenu, any chance of having the cycles to fix the generation of notifications for newly sent mail in the sent folder for beta 2?
Comment 6 Mark Banner (:standard8) 2010-05-06 06:30:49 PDT
Given where we are, not going to try and assign this to a 3.0 release as it is more appropriate in a later release.
Comment 7 Jonathan Protzenko [:protz] 2010-12-17 01:28:03 PST
:bienvenu, :asuth, given the current activity around these issues, do you think we could target a fix for the 3.3 release?
Comment 8 David :Bienvenu 2010-12-17 07:27:07 PST
(In reply to comment #7)
> :bienvenu, :asuth, given the current activity around these issues, do you think
> we could target a fix for the 3.3 release?

I'm trying to get it into 3.3 but it doesn't block 3.3, I don't believe.
Comment 9 Andrew Sutherland [:asuth] 2011-01-15 12:46:46 PST
Created attachment 504159 [details] [diff] [review]
v1 utilize the new msgKeyChanged notification

This patch depends on the fix from bug 574441.

The focal point of the patch is that the gloda move test has been modified to use "fast-path" offline operations in the "move it there" case and (continue to) not to use offline operations in the "move it back".  We verify that in the fast-path case gloda does not attempt to reindex the message but in the slow-path case it does.  (Gloda will still generate itemsModified notifications, though.)  We also verify that the book-keeping dictionary does not leak cruft.

I also used logsploder to make sure the event sequence in the tests looks sane.
Comment 10 Andrew Sutherland [:asuth] 2011-01-19 16:51:32 PST
pushed to trunk:
http://hg.mozilla.org/comm-central/rev/afa759fe196c
Comment 11 Andrew Sutherland [:asuth] 2011-01-20 01:28:17 PST
protz makes a good point in IRC that we didn't actually fix what the subject of this bug is about, so I am reopening.

The patch I landed is a nice patch, but I only put it on this bug because it seemed like gloda should otherwise already be doing all the right things and the dependency suggested this was a good place to put it.

We should only close this bug once we have a test that verifies the thing the subject says.  I have no idea why the desired result is not happening, and a further complication is that I'm not entirely sure our current test framework allows us to realistically test the situation.  (At least, the gloda framework.  Gloda forces updateFolders...)

protz, if you would like to pursue this or otherwise look into it, please be my guest :)
Comment 12 Wayne Mery (:wsmwk, NI for questions) 2011-02-15 20:35:08 PST
protz, what amount of delay do you typically see?

(don't think I've ever seen this - perhaps I have immunity because I configure Sent pointing to Inbox, and put replies in same folder as original)
Comment 13 Mike Gratton 2011-03-20 06:05:58 PDT
*** Bug 640553 has been marked as a duplicate of this bug. ***
Comment 14 Jonathan Protzenko [:protz] 2011-05-07 01:39:03 PDT
The issue I describe here was just fixed by bug 646226.

Note You need to log in before you can comment on or make changes to this bug.