Browser crashes when printing [@ objc_msgSend | CanonIJPDE@0x15cce]

RESOLVED DUPLICATE of bug 460963

Status

()

Core
Printing: Setup
--
critical
RESOLVED DUPLICATE of bug 460963
8 years ago
7 years ago

People

(Reporter: Jay, Unassigned)

Tracking

({crash})

1.9.1 Branch
Other
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [canon driver], crash signature)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 GTB6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 GTB6

Whenever I try to print a web page from the browser, the browser crashes.  Once I restart it and navigate back to the page, I can print the page without the browser crashing.  But if I go to another website and try to print, the whole browser (including all the tabs I have open) crashes again. This seems to happen particularly when I have multiple tabs open. 

Reproducible: Always

Steps to Reproduce:
1. Open multiple pages in multiple tabs
2.  Try to print a web page

Actual Results:  
Browser crashes

Expected Results:  
Printed without crashing
Reporter, can you please go to about:crashes and get a crash id?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
should explain it
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 4

8 years ago
Signature	objc_msgSend | CanonIJPDE@0x15cce
UUID	4d733850-21df-4c99-a5ad-971042091212
Time 	2009-12-12 17:56:30.376152
Uptime	382
Last Crash	387 seconds before submission
Product	Firefox
Version	3.5.5
Build ID	20091102134505
Branch	1.9.1
OS	Mac OS X
OS Version	10.5.8 9L31a
CPU	x86
CPU Info	GenuineIntel family 6 model 7 stepping 6
Crash Reason	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash Address	0x92355699
User Comments	Trying to print a document from the web
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libobjc.A.dylib 	objc_msgSend 	
1 	CanonIJPDE 	CanonIJPDE@0x15cce 	
2 	CanonIJPDE 	CanonIJPDE@0x15d91 	
3 	CanonIJPDE 	CanonIJPDE@0x17a97 	
4 	CanonIJPDE 	CanonIJPDE@0x179d0 	
5 	Foundation 	_nsnote_callback 	
6 	CoreFoundation 	__CFXNotificationPost 	
7 	CoreFoundation 	_CFXNotificationPostNotification 	
8 	Foundation 	-[NSNotificationCenter postNotificationName:object:userInfo:] 	
9 	Foundation 	-[NSNotificationCenter postNotificationName:object:] 	
10 	CanonIJPDE 	CanonIJPDE@0x1759e 	
11 	CanonIJPDE 	CanonIJPDE@0x7986 	
12 	CanonIJPDE 	CanonIJPDE@0x1f3a 	
13 	PrintCocoaUI 	PrintCocoaUI@0x63b0 	
14 	PrintCocoaUI 	PrintCocoaUI@0x4a9f 	
15 	PrintCocoaUI 	PrintCocoaUI@0x315b 	
16 	PrintCocoaUI 	PrintCocoaUI@0x18721 	
17 	PrintCocoaUI 	PrintCocoaUI@0x22744 	
18 	AppKit 	-[NSWindowController _windowDidLoad] 	
19 	AppKit 	-[NSWindowController window] 	
20 	PrintCocoaUI 	PrintCocoaUI@0x1da84 	
21 	PrintCocoaUI 	PrintCocoaUI@0xd535 	
22 	Print 	sessionPrintDialog 	
23 	XUL 	nsPrintingPromptService::ShowPrintDialog 	embedding/components/printingui/src/mac/nsPrintingPromptServiceX.mm:348
24 	XUL 	nsPrintEngine::DoCommonPrint 	layout/printing/nsPrintEngine.cpp:620
25 	XUL 	nsPrintEngine::CommonPrint 	layout/printing/nsPrintEngine.cpp:447
26 	XUL 	nsPrintEngine::Print 	layout/printing/nsPrintEngine.cpp:758
27 	XUL 	DocumentViewerImpl::Print 	layout/base/nsDocumentViewer.cpp:3619

Filename 	Version 	Debug Identifier 	Debug Filename
BJPDELocalizedString2 		7B02F9902E978FD3E1DAA6D8A9D4937A0 	BJPDELocalizedString2
PrintPDE 		4C5A25A647C127232FBBFDFAB9AFD3DC0 	PrintPDE
libfrozen.dylib 		1116D2C5784BD1CE06919725DE7D7D290 	libfrozen.dylib
BJCommand2 		DD9BA1FDD845C6697EFF6DB5000E53350 	BJCommand2
CIJPrinterUtility 		85A186C978E67266227ACF6BA2416EB60 	CIJPrinterUtility
libPDFRIP.A.dylib 		083E8CFA13C3A61D66AA664D74B00C3B0 	libPDFRIP.A.dylib
BJStatus2 		C5D3A9794C08150F4F306421AF493D510 	BJStatus2
PrintCocoaUI 		C3A9176121F98A2BCC3E85E053B2B6610 	PrintCocoaUI
PrintingCocoaPDEs 		9B31B71CE904E3D409E8310276702AAB0 	PrintingCocoaPDEs
CanonIJPDE 		E34A3E8B5B900A716C624A4028E856EF0 	CanonIJPDE
PrintCore 		03D0585059C20CB0BDE5E000438C49E10 	PrintCore

Your problem is caused by your printer driver, please complain to canon.

fwiw, bp-49d2c9d4-b59c-440e-9786-1ef7a2091213 is an unrelated crash in javascript.
Severity: normal → critical
Component: General → Printing: Setup
Keywords: crash
Product: Firefox → Core
QA Contact: general → printing.setup
Summary: Browser crashes when printing → Browser crashes when printing [@ objc_msgSend | CanonIJPDE@0x15cce]
Version: unspecified → 1.9.1 Branch

Comment 5

8 years ago
Jay, is this improved with a newer driver?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID

Updated

7 years ago
Resolution: INVALID → DUPLICATE
Whiteboard: [canon driver]
Duplicate of bug: 460963
(Assignee)

Updated

7 years ago
Crash Signature: [@ objc_msgSend | CanonIJPDE@0x15cce]
You need to log in before you can comment on or make changes to this bug.