Closed Bug 534676 Opened 12 years ago Closed 12 years ago

Crash when trying to profile in Firebug [@ JS_HashTableDestroy ]

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla1.9.3a1
Tracking Status
status1.9.2 --- final-fixed

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

Details

(Keywords: crash, regression, verified1.9.2)

Crash Data

Attachments

(1 file)

This is a regression from bug 534120.  We end up with dangling object tables and lose.  Fix is to not actually finish the object table on pause, but to just destroy our jsdobjects.
Flags: blocking1.9.2?
Attached patch FixSplinter Review
Attachment #417512 - Flags: review?
Attachment #417512 - Flags: review? → review?(timeless)
Attachment #417512 - Flags: review?(timeless) → review+
Attachment #417512 - Flags: approval1.9.2?
Duplicate of this bug: 534755
Status: NEW → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
Crash reports show the same stack as with Venkman. Updating summary to get a connection to crashstats.
Severity: normal → critical
Keywords: crash, regression
Summary: Crash when trying to profile in Firebug → Crash when trying to profile in Firebug [@ JS_HashTableDestroy ]
Comment on attachment 417512 [details] [diff] [review]
Fix

a192=beltzner
Attachment #417512 - Flags: approval1.9.2? → approval1.9.2+
Also adding blocking; this needs to be resolved, hopefully by this fix, but if not, then by a backout of bug 534120
Flags: blocking1.9.2? → blocking1.9.2+
Pushed http://hg.mozilla.org/mozilla-central/rev/f4e5b9438d17
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
No more crashes visible on crashstats. I wasn't even able to reproduce the crash anymore on my own. Marking as verified on trunk and 1.9.2.
Status: RESOLVED → VERIFIED
Keywords: verified1.9.2
Target Milestone: --- → mozilla1.9.3a1
Crash Signature: [@ JS_HashTableDestroy ]
Component: JavaScript Debugging/Profiling APIs → JavaScript Engine
You need to log in before you can comment on or make changes to this bug.