Closed Bug 534755 Opened 12 years ago Closed 12 years ago

Firefox crashes on shutdown and Venkman installed [@ JS_HashTableDestroy ]

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 534676

People

(Reporter: tchung, Unassigned)

References

()

Details

(Keywords: crash, regression)

Crash Data

I hit this after updating a nightly trunk build today.   The last time my build was updated was Dec 11th buildID: 20091211032725

Using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20091214 Minefield/3.7a1pre.

http://crash-stats.mozilla.com/report/index/bp-7f94e97d-a9c6-44fb-81d9-af6522091214

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libmozjs.dylib 	JS_HashTableDestroy 	js/src/jshash.cpp:150
1 	XUL 	jsd_DestroyObjectManager 	js/jsd/jsd_obj.c:245
2 	XUL 	jsd_DebuggerOff 	js/jsd/jsd_high.c:177
3 	XUL 	jsdService::Off 	js/jsd/jsd_xpc.cpp:2624
4 	XUL 	XUL@0x9e7f5c 	
5 	XUL 	jsdService::Release 	js/jsd/jsd_xpc.cpp:2339
6 	XUL 	nsCOMPtr_base::assign_with_AddRef 	xpcom/glue/nsCOMPtr.h:456
7 	XUL 	FreeServiceContractIDEntryEnumerate 	
8 	XUL 	PL_DHashTableEnumerate 	pldhash.c:754
9 	XUL 	nsComponentManagerImpl::FreeServices 	xpcom/components/nsComponentManager.cpp:1749
10 	XUL 	mozilla::ShutdownXPCOM 	xpcom/build/nsXPComInit.cpp:743
11 	XUL 	XUL@0x4768 	
12 	XUL 	XRE_main 	toolkit/xre/nsAppRunner.cpp:1020
13 	firefox-bin 	main 	browser/app/nsBrowserApp.cpp:158
14 	firefox-bin 	firefox-bin@0xbf5 	
15 		@0x0

Extensions installed:
        
Crash Me Now!0.1truecrashme@ted.mielczarek.org
Weave1.0b2true{340c2bbc-ce74-4362-90b5-7c26312808ef}
Tab Preview0.3false{1de0de3c-0b5c-4f67-90c6-689623894991}
Icon Test Extension1.0false{f34f3ceb-f04f-4d4d-b6dd-46ac1dc7b349}
JavaScript Debugger0.9.87.4true{f13b157f-b174-47e7-a34d-4815ddfdfeb8}
Personas1.4falsepersonas@christopher.beard
Severity: normal → critical
This is a new crash on trunk and given by Socorro it has been started between the builds 12/12 - 12/13.

Check-ins in this timeframe:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d379a17cbf8f&tochange=3ff17b03644e

I hit the same crash on startup (uptime 15s) a couple of minutes before:
http://crash-stats.mozilla.com/report/index/bp-21b06dde-0715-40ef-802e-4f4e12091214

We would need reliable steps to reproduce for a regression test.
OS: Mac OS X → All
Hardware: x86 → All
Summary: Crash [@ JS_HashTableDestroy ], when updating a nightly trunk build → Firefox crashes when upgrading nightly build [@ JS_HashTableDestroy ]
Eventually caused by bug 534120?
Steps:
1. Install Venkman in a recent Minefield build
2. Close Firefox

This crash happens on each shutdown for me with Venkman installed.
Bug 534120 is really the only possible candidate here.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 534676
Status: RESOLVED → VERIFIED
Summary: Firefox crashes when upgrading nightly build [@ JS_HashTableDestroy ] → Firefox crashes on shutdown and Venkman installed [@ JS_HashTableDestroy ]
Crash Signature: [@ JS_HashTableDestroy ]
You need to log in before you can comment on or make changes to this bug.