The default bug view has changed. See this FAQ.

Port |Bug 384179 - crash on startup| to SeaMonkey

RESOLVED FIXED in seamonkey2.1b1

Status

SeaMonkey
Build Config
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

(Depends on: 1 bug)

Trunk
seamonkey2.1b1
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed in, 2.1a2: Av1; 2.1b1: Bv3], URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

7 years ago
I guess we need to port that bug!?
Flags: in-testsuite-
(Assignee)

Updated

7 years ago

Comment 1

7 years ago
Serge, have we actually fixed this with our recent updates of packaging files?
(Assignee)

Comment 2

7 years ago
(In reply to comment #1)

I would assume it's not (fully): SM removed-files.in has no |#ifdef MOZ_ENABLE_LIBXUL| yet...
NB: The |#ifndef MOZ_ENABLE_LIBXUL| part may not be perfect, but I assume we should be safe with what we have.

No real need to look into this until we are closer to supporting libxul builds.
Assignee: nobody → installer
Component: Build Config → Installer
QA Contact: build-config → xpi-packages

Comment 3

7 years ago
I don't want to split hairs, but I see package-manifest and removed-files more as build config than as installer, esp. regarding what people do work on what component. Installer tends to be the Windows NSIS installer only these days.
(Assignee)

Updated

7 years ago
Assignee: installer → nobody
Component: Installer → Build Config
QA Contact: xpi-packages → build-config
Morphing to NEW; we'll want this in some way; I did not verify if it is already fixed however.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

7 years ago
Depends on: 563012
(Assignee)

Updated

7 years ago
No longer blocks: 394502
Depends on: 394502
(Assignee)

Comment 5

7 years ago
Created attachment 445368 [details] [diff] [review]
(Av1) Just be more specific wrt MOZ_STATIC_BUILD, ftb
[Checkin: Comment 6]
Attachment #445368 - Flags: review?(bugspam.Callek)
(Assignee)

Updated

7 years ago
Attachment #445368 - Flags: review?(kairo)

Updated

7 years ago
Attachment #445368 - Flags: review?(kairo)
Attachment #445368 - Flags: review?(bugspam.Callek)
Attachment #445368 - Flags: review+
(Assignee)

Comment 6

7 years ago
Comment on attachment 445368 [details] [diff] [review]
(Av1) Just be more specific wrt MOZ_STATIC_BUILD, ftb
[Checkin: Comment 6]


http://hg.mozilla.org/comm-central/rev/0b91c20ad258
Attachment #445368 - Attachment description: (Av1) Just be more specific wrt MOZ_STATIC_BUILD, ftb → (Av1) Just be more specific wrt MOZ_STATIC_BUILD, ftb [Checkin: Comment 6]
(Assignee)

Comment 7

7 years ago
     1.7 +#ifdef MOZ_ENABLE_LIBXUL

     1.8 +@DLL_PREFIX@xpcom_core@DLL_SUFFIX@
     1.9 +components/@DLL_PREFIX@jar50@DLL_SUFFIX@
    1.10 +#ifdef XP_WIN
    1.11 +components/jsd3250.dll
    1.12 +components/xpinstal.dll
    1.13 +#else
    1.14 +components/@DLL_PREFIX@jsd@DLL_SUFFIX@
    1.15 +components/@DLL_PREFIX@xpinstall@DLL_SUFFIX@
    1.16 +#endif
    1.17 +components/@DLL_PREFIX@jar50@DLL_SUFFIX@

xpcom_core and jsd(3250) fixed by bug 394502.
xpinstal(l) fixed by bug 563012.
jar50 is still a todo.

    1.18 +#else

    1.19 +#ifdef XP_MACOSX
    1.20 +XUL
    1.21 +#else
    1.22 +@DLL_PREFIX@xul@DLL_SUFFIX@
    1.23 +#endif

Fixed by patch Av1 (and older).

    1.24 +#endif
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
(Assignee)

Comment 8

7 years ago
Created attachment 477715 [details] [diff] [review]
(Bv1) Do+Fix the libxul part

*Reorder [xpcom], while there.
*Do jar50, this bug.
*Fix xpcomcor/xpcom_core and jsd3250, from bug 394502 bad fix.
Attachment #477715 - Flags: review?(kairo)
(Assignee)

Updated

7 years ago
Blocks: 598644

Comment 9

7 years ago
(In reply to comment #7)
> jar50 is still a todo.

IIRC, this is in my bug 598644 patch.

Note that static builds are unsupported now after bug 394502 and packaging of shared build is also not supported any more, they are a pure developer-private option only until they will go completely unsupported on the m-c side later.

Comment 10

7 years ago
Comment on attachment 477715 [details] [diff] [review]
(Bv1) Do+Fix the libxul part

1) See my comment from before.
2) I see no reason for removing anything from removed-files here unless you can argument it with those files never having been in any 2.x milestone.
Attachment #477715 - Flags: review?(kairo) → review-
(Assignee)

Updated

7 years ago
No longer blocks: 598644
Depends on: 598644
(Assignee)

Comment 11

7 years ago
Created attachment 477922 [details] [diff] [review]
(Bv2) Fix the libxul part

*Reorder [xpcom], while there.
*Fully remove gkdebug handling, leftover from bug 598644.
*Fully fix jar50, leftover from bug 598644.
*Fix xpcomcor/xpcom_core and jsd3250, from bug 394502 bad fix.


(In reply to comment #9)

> IIRC, this is in my bug 598644 patch.

Indeed, but missing removed-files.in update.

> Note that static builds are unsupported now after bug 394502 and packaging of
> shared build is also not supported any more, they are a pure developer-private
> option only until they will go completely unsupported on the m-c side later.

So I understood.


(In reply to comment #10)
> 2) I see no reason for removing anything from removed-files here unless you can
> argument it with those files never having been in any 2.x milestone.

I'm not sure I understand what you mean :-/
*gkdebug was debug 2.1 only.
*jar50 and xpcom_core were in 2.0.x release.
*jsd3250 was just a bad copy+paste.
Attachment #477715 - Attachment is obsolete: true
Attachment #477922 - Flags: review?(kairo)

Comment 12

7 years ago
Comment on attachment 477922 [details] [diff] [review]
(Bv2) Fix the libxul part

1) Please no "just reordering because it's fun" patches.
2) As I explained in bug 598644, we don't need any changes to removed-files, as we never shipped those libraries in 2.x milestones.
Attachment #477922 - Flags: review?(kairo) → review-

Comment 13

7 years ago
Actually, regarding removed-files, you might be right.

(In reply to comment #11)
> *gkdebug was debug 2.1 only.

OK, then it was a bug we even added it to that file, you're right in killing it.

> *jar50 and xpcom_core were in 2.0.x release.

You mean, they were present in 2.0.x releases as we shipped them? If so, we need to have them in removed-files.

> *jsd3250 was just a bad copy+paste.

OK, then let's kill it.
(Assignee)

Comment 14

7 years ago
Created attachment 477927 [details] [diff] [review]
(Bv3) Fix the libxul part
[Checked in: Comment 15]

(In reply to comment #13)

> You mean, they were present in 2.0.x releases as we shipped them? If so, we
> need to have them in removed-files.

Yes, they still are in en-US Windows seamonkey-2.0.8.zip for example!

> OK, then let's kill it.

Not kill: fix!
Attachment #477922 - Attachment is obsolete: true
Attachment #477927 - Flags: review?(kairo)

Updated

7 years ago
Attachment #477927 - Flags: review?(kairo) → review+
(Assignee)

Comment 15

7 years ago
Comment on attachment 477927 [details] [diff] [review]
(Bv3) Fix the libxul part
[Checked in: Comment 15]

http://hg.mozilla.org/comm-central/rev/f9fe8f8696a2
Attachment #477927 - Attachment description: (Bv3) Fix the libxul part → (Bv3) Fix the libxul part [Checked in: Comment 15]
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in, 2.1a2: Av1; 2.1b1: Bv3]
Target Milestone: --- → seamonkey2.1b1
(Assignee)

Updated

5 years ago
Depends on: 526333
You need to log in before you can comment on or make changes to this bug.