Delay when attempting to read mail with intermittent "(not responding)" and gloda indexing turned off

RESOLVED DUPLICATE of bug 599119

Status

Thunderbird
Message Reader UI
--
major
RESOLVED DUPLICATE of bug 599119
9 years ago
8 years ago

People

(Reporter: josh.hrach, Unassigned)

Tracking

({perf})

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.33 Safari/532.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

I have a fresh install of Thunderbird 3. This was installed into a separate folder from Thunderbird 2. I was grateful to find that I could easily import and work with my mail in Thunderbird 3.

Here is the issue:

For most tasks, Thunderbird 3 performs flawlessly. However, when attempting to read an email (for example, clicking on an email in the upper right pane), it takes between 11 and 15 seconds for the email to appear in the lower right pane. During this time, CPU usage for Thunderbird jumps from ~5% to ~50% and Vista grays out Thunderbird and says it is "not responding". This happens with any email that I have, whether pure text or not.

Reproducible: Always

Steps to Reproduce:
For me...

1. Choose any folder in any account
2. Click on any email in that folder
3. Wait 11-15 seconds for Thunderbird to respond.
Actual Results:  
After the waiting period, Thunderbird will drop out from being 'non responsive' and will return to normal. Doing any operation that would bring the focus to a new email, whether clicking on a new email or deleting the current one, requires another 11-15 seconds of Thunderbird being locked up before the email will appear.

Expected Results:  
With Thunderbird 2, emails took only a second, if that, to load in the lower right pane. Opening an email should not be so difficult. This wait makes the product a time waster and worthless when emails are coming in often. There is no way to keep up with a stream of new emails to either read or delete if it takes over 10 seconds to just process it in Thunderbird to do anything with it.

I have not installed any themes or addons to Thunderbird 3.

Comment 1

9 years ago
What do you have in status bar and activity manager (AM) during these periods? 
(overlap windows so you can see what's happening in AM)
Keywords: perf
Summary: Thunderbird locks up when attempting to read mail → Thunderbird locks up when attempting to read mail with intermittent "not responding"
Version: unspecified → 3.0
(Reporter)

Comment 2

9 years ago
Status bar and activity manager are both blank. There is no flash of any messages during those periods on either.
Can you spec your machine so we can get an idea ?
(Reporter)

Comment 4

9 years ago
I assume you're wanting the following:

It's a Dell XPS M1330 running Windows Vista Ultimate (32-bit) with Service Pack 1.

2.00 GB RAM
Intel Core 2 Duo CPU T5450 @ 1.66GHZ

If you need more information, let me know. I wasn't sure what to include.
That's enough thanks.

Comment 6

9 years ago
what antivirus program do you have running?
(Reporter)

Comment 7

9 years ago
I'm running the latest version of avast! running under a home registration.

Comment 8

9 years ago
josh, do you also see the problem in 3.0.1?
Does the problem go away at any point in the procedure at https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems#Diagnosis:
(Reporter)

Comment 9

9 years ago
Yes, I still am having the issue with 3.0.1. 

Unfortunately, no, the problem didn't go away during any of those steps. I was unable to get a msgdb log (though I did follow the steps for setting it up). Beyond that, I completed those steps and the problem still existed.

Comment 10

9 years ago
so you still see the problem if global indexing and antivirus are turned off?

(if it is off, you should not see any indexing info in status bar and Tools|Activity Manager)

When you see "not responding", is CPU usage high?
(Reporter)

Comment 11

9 years ago
To your first question: Yes, I still see the problem.

As an update to that: I decided to try something different and uninstalled Trend Micro and Web Sweeper. With them gone, the delay between emails is now 5-6 seconds instead of the higher amount that I had earlier.

When Thunderbird shows up as 'not responding', or when I'm clicking from one email to another, memory usage goes up by 4K (and that 4K remains as I go from email to email, even back to email I have already read). The CPU will go from 0 or 2% up to 50-60%.

Comment 12

8 years ago
josh, does this improve for you if you change View | Message Body as | simple html ?

adding "and gloda indexing turned off" to summary
Summary: Thunderbird locks up when attempting to read mail with intermittent "not responding" → Thunderbird locks up when attempting to read mail with intermittent "(not responding)" and gloda indexing turned off
(Reporter)

Comment 13

8 years ago
No, there is no improvement in performance when this change is made.

Comment 14

8 years ago
josh, if this has not improved with v3.0.4, or 3.0.5 which comes out shortly, then please try version 3.1 when it releases and update the bug.
Whiteboard: closeme 2010-07-17 [needs recheck]
(Reporter)

Comment 15

8 years ago
Just tried 3.1.2. Delay is at around 5 seconds between clicking on an email and something coming up in the preview area, even for simple text emails.

Updated

8 years ago
Summary: Thunderbird locks up when attempting to read mail with intermittent "(not responding)" and gloda indexing turned off → Delay when attempting to read mail with intermittent "(not responding)" and gloda indexing turned off
Whiteboard: closeme 2010-07-17 [needs recheck]
Does setting plugin.scan.plid.all to false in the config editor solve your problem? If it does, this bug is a duplicate of bug 599119.
(Reporter)

Comment 17

8 years ago
It seems to, yes. Response time is definitely much faster.
Right, thanks. We're looking at it in bug 599119.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599119
You need to log in before you can comment on or make changes to this bug.