Mailing List dialog not resizable

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Hb, Assigned: philip.chee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
The Mailing List dialog window should be resizable as in Thunderbird.
(Assignee)

Comment 1

9 years ago
The Mailing List dialogs (New List, Edit List) are not resizable in Shredder either.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
While this may be true (I didn't check) that actually isn't an argument. ;-)
(Assignee)

Comment 3

9 years ago
In which case this should be an enhancement bug not a bugfix bug.
You're right...
Severity: normal → enhancement
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Updated

9 years ago
Status: REOPENED → NEW
(Assignee)

Comment 5

9 years ago
Created attachment 434524 [details] [diff] [review]
Patch v1.0 resizable mailing list dialogs.

> The Mailing List dialog window should be resizable as in Thunderbird.
Minimal patch.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #434524 - Flags: review?(mnyromyr)
Comment on attachment 434524 [details] [diff] [review]
Patch v1.0 resizable mailing list dialogs.

Okay in a minimal way, although my KDE doesn't care anyway (I can resize all windows, hence I tested on Mac. 

MXRing for resizable=no it seems that only addressbook stuff is affected anyway, so maybe it's worth fixing all these in one row.

Furthermore, I noticed two glitches:
- the resized dialogs don't remember their size 
- abListOverlay.xul sports some odd <spacer flex="1"/> elements which push the mailing list header textboxen to the right edge. That looks very weird. Unfortunately, that file is shared (although a decent fix should be possible still).
Attachment #434524 - Flags: review?(mnyromyr) → review+
(In reply to comment #6)
> Unfortunately, that file is shared

Oh, but it isn't! So we could just move it home...
(Assignee)

Comment 8

9 years ago
Comment on attachment 434524 [details] [diff] [review]
Patch v1.0 resizable mailing list dialogs.

> MXRing for resizable=no it seems that only addressbook stuff is affected
> anyway, so maybe it's worth fixing all these in one row.

> Furthermore, I noticed two glitches:
> - the resized dialogs don't remember their size

Should they remember their size? What is the suite policy about remembering the size in resizable dialogs?

> - abListOverlay.xul sports some odd <spacer flex="1"/> elements which push the
> mailing list header textboxen to the right edge. That looks very weird.

CVS blame says that this has been the case since checkin (although they were springs initially).

> Unfortunately, that file is shared (although a decent fix should be possible
> still).

> Oh, but it isn't! So we could just move it home...

A separate bug perhaps for all these glitches?
Attachment #434524 - Flags: superreview?(neil)
(Assignee)

Comment 9

9 years ago
> MXRing for resizable=no it seems that only addressbook stuff is affected
> anyway, so maybe it's worth fixing all these in one row.

OK.

> - the resized dialogs don't remember their size

I'll fix the Mail List dialogs, but the others appear to be shared with TB.

> - abListOverlay.xul sports some odd <spacer flex="1"/> elements which push the
> mailing list header textboxen to the right edge. That looks very weird.

Filed Bug 555452 for this issue.
(Assignee)

Comment 10

9 years ago
>> MXRing for resizable=no it seems that only addressbook stuff is affected
>> anyway, so maybe it's worth fixing all these in one row.
> OK.

After testing a bit, I've decided that it makes no sense to make the other dialogs resizable since the sizes of the contents of these don't resize.

I'm not sure of the utility of making the mailing list dialogs resizable either after testing. Neil?
Once bug 555452 is fixed I have no objection to making them resizable, but I am as yet undecided as to whether the size and/or position should be persisted.
Depends on: 555452
(In reply to comment #11)
> I am as yet undecided as to whether the size and/or position should
> be persisted.

My personal reasoning would go along the lines of "If I'm allowed to resize this dialog and I want to as well, it should stay that size." 
Resizable dialogs which snap back to their own size are pretty much annoying, IMO.
(Assignee)

Comment 13

9 years ago
My opinion, less is more. Leave the persists off until someone (a real user *not* *you*) complains and files a bug.
Attachment #434524 - Flags: superreview?(neil) → superreview+
(Assignee)

Comment 14

9 years ago
checked-in http://hg.mozilla.org/comm-central/rev/17e1829c4c41
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.