Closed Bug 555452 Opened 10 years ago Closed 10 years ago

[Addressbook] Mail List Dialog header sections should use <hbox align="end"> instead of spacers to align the labels.

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: philip.chee, Assigned: philip.chee)

References

Details

Attachments

(1 file, 1 obsolete file)

From Bug 534831 Comment 6

> - abListOverlay.xul sports some odd <spacer flex="1"/> elements which push the
> mailing list header textboxen to the right edge. That looks very weird.

I think that the intention was to right align the labels. We should switch these to a grid and wrap the labels with a <hbox align="end"> instead.
Blocks: 534831
First time I'm doing a move. make -C $OBJDIR$ tier_apps seems happy with this.

> -             accesskey="&ListName.accesskey;" class="CardEditLabel"/>

No CSS for CardEditLabel was found in comm-central so I removed these from the XUL.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #436687 - Flags: superreview?
Attachment #436687 - Flags: review?(mnyromyr)
Attachment #436687 - Flags: feedback?(neil)
Attachment #436687 - Flags: superreview?
Comment on attachment 436687 [details] [diff] [review]
Patch v1.0 Move to suite and switch to using a grid.

>+      <row>
>+        <hbox align="center" pack="end">
The align would look better on the row.

>+                 class="CardEditWidth"/>
This could go on the column, I think.

(In reply to comment #1)
> No CSS for CardEditLabel was found in comm-central so I removed these from the
> XUL.
Actually we could style them with text-align: right; to avoid the hbox.
Attachment #436687 - Flags: feedback?(neil) → feedback+
> (From update of attachment 436687 [details] [diff] [review])
>>+      <row>
>>+        <hbox align="center" pack="end">
> The align would look better on the row.
Fixed.

>>+                 class="CardEditWidth"/>
> This could go on the column, I think.
Fixed.

> (In reply to comment #1)
>> No CSS for CardEditLabel was found in comm-central so I removed these from the
>> XUL.
> Actually we could style them with text-align: right; to avoid the hbox.
Fixed.
Attachment #436687 - Attachment is obsolete: true
Attachment #442654 - Flags: superreview?(neil)
Attachment #442654 - Flags: review?(mnyromyr)
Attachment #436687 - Flags: review?(mnyromyr)
Comment on attachment 442654 [details] [diff] [review]
Patch v1.1 nits fixed.

>+      <column class="CardEditWidth"
>+              flex="1"/>
Wasn't necessary to wrap this, it fits on one line.
Attachment #442654 - Flags: superreview?(neil) → superreview+
>>>+      <column class="CardEditWidth"
>>>+              flex="1"/>
> Wasn't necessary to wrap this, it fits on one line.

Fixed locally. Waiting for review.
Comment on attachment 442654 [details] [diff] [review]
Patch v1.1 nits fixed.

>+++ b/suite/mailnews/addrbook/abListOverlay.xul
>-                 autocompletesearch="addrbook" timeout="300" maxrows="4" 
>+                 autocompletesearch="addrbook" timeout="300" maxrows="4"
>                  completedefaultindex="true" forcecomplete="true"

Transform these two lines to "one line per attribute" as well.

r=me with that.

(The listbox in these dialogs is a true beauty: a fixed height plus predefined listitems for the visible area. Spending a flex made me admire your well-considered bug scope. *g*)
Attachment #442654 - Flags: review?(mnyromyr) → review+
Checked-in
http://hg.mozilla.org/comm-central/rev/23337051ed93
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 543129
You need to log in before you can comment on or make changes to this bug.