Default font-style changes abruptly to "Variable width"

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
P1
major
RESOLVED DUPLICATE of bug 250539
8 years ago
8 years ago

People

(Reporter: crimle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0

The default font-style changes abruptly to "Variable width" if you
- change the paragraph format to bulleted list
- change the paragraph format to numbered list
- insert a table
- insert a horizontal line

Reproducible: Always

Steps to Reproduce:
1. Go to Tools > Settings > Compose
2. Select for exemple Font = "Arial" and Size = "Small" as your preferred font-style
3. Click the "Compose" icon to create a new mail
4. Begin writing text (you will get your text with "Arial small"; OK so far)
5. Press the [Enter] key to begin a new line
6. Do one of the following actions:
   - change the paragraph format to bulleted list
   - change the paragraph format to numbered list
   - insert a table
   - insert a horizontal line
Actual Results:  
- Have a look at the font-style drop-box: the font has changed to "Variable width"
- Have a look at the "Format > Font Size" menu: the fint-size has changed to "medium"

The bug occurs if you first begin a new paragraph, then change the paragraph format and finally write the text.

The bug does NOT occur if you first write the text and then change the paragraph format.

Expected Results:  
The font-style should always remain as it was predefined as default in the Tools > Settings > Compose menu.

This is a very old bug and has been reported for Thunderbird 2.x. It is very annoying, since you have to check and change the text format manually before sending every single mail. Unless you don't care how your mail looks like...
(Reporter)

Updated

8 years ago
Priority: -- → P1
Version: unspecified → 3.0
Whiteboard: dupeme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.