Closed Bug 534936 Opened 12 years ago Closed 11 years ago

message move through IMAP it is not atomic

Categories

(MailNews Core :: Networking: IMAP, defect)

1.9.1 Branch
x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 636285

People

(Reporter: spam, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

When one moves multiple messages from one folder to another through IMAP connection the operation it is not atomic regarding the single message. If the operation ends abruptly before completion (i.e. for crash) then the already copied messages can be find in the destination folder _and_ in the source folder.
You might fix this by deleting single messages in source folder as soon as you have the confirmation of successful copying in the destination one.
I am wondering that this affects moving between local folders too, but I am not able to test it.

Reproducible: Always

Steps to Reproduce:
1. log in to a IMAP account
2. select a lot of messages (for example one hundred)
3. select "move to" or drag to a local folder or to a folder of another account
4. interrupt operation before completion, for example by closing TB
Actual Results:  
Already copied messages before interruption are present in both folders

Expected Results:  
Copied messages should be present only in destination folder
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Version: unspecified → 1.9.1 Branch
bug 636285 is probably the only fix for this
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 636285
You need to log in before you can comment on or make changes to this bug.