add support for IMAP Move RFC

RESOLVED FIXED in Thunderbird 3.3a3

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

unspecified
Thunderbird 3.3a3
x86
Windows 7
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Assignee

Description

8 years ago
Posted patch proposed fixSplinter Review
We'd like to add support for the proposed IMAP Move extension.

This leverages the work already done to support the AOL Move extension. Most of the work was enhancing the testing harness to be able to test the MOVE support, and writing a test for it.

This patch also starts work on adding support for HighestModSeq, since I already had to change the capability code for Move.
Attachment #514631 - Flags: review?(bugzilla)
Comment on attachment 514631 [details] [diff] [review]
proposed fix

Ok, this looks good, I don't think I've got a server that supports this, but the test looks right, so lets get it out for some testing.

I've got a few style nits (mainly . at the start of a line, and 2 space indents rather than 3), so I'll just address those and land it for you.
Attachment #514631 - Flags: review?(bugzilla) → review+
Checked in: http://hg.mozilla.org/comm-central/rev/141c656b38ea
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a3
Assignee

Comment 3

8 years ago
Thanks for landing this.

Updated

8 years ago
Duplicate of this bug: 534936
Thanks. This will probably also fix Bug 573729 if the server supports MOVE.

Comment 6

8 years ago
Hi David, is this in 3.1.9?

I just added support for MOVE to our IMAP server, and having to test it with telnet, since I can't get 3.1.9 to send a MOVE command.

Regards

Adrien
Assignee

Comment 7

8 years ago
No but its in the latest 3.3 alpha

Comment 8

8 years ago
OK, thanks for that - it seems to be working fine in terms of doing the move.  It's a good and worth-while extension, pity it's only an expired Internet Draft.

One optimisation that could be added at a later stage if anyone has too much time on their hand.

With a move, if the server gives you a COPYUID response (which it should), you should be able to match the source with the destination of the move, and populate the local index with the information from the source mailbox.  Save doing a fetch on the target mailbox to re-learn information you previously had.
You need to log in before you can comment on or make changes to this bug.