Closed Bug 535634 Opened 11 years ago Closed 8 years ago

Thunderbird Should Use the Open With Dialog from Nautilus

Categories

(Thunderbird :: OS Integration, enhancement)

x86
Linux
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 397700

People

(Reporter: mlissner+bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7pre) Gecko/20091212 Ubuntu/9.10 (karmic) Firefox/3.5.2
Build Identifier: 3.0

When opening an attached file, if a user presses the 'open with' drop down, and then selects "Other...", TB should implement the Nautilus API to use the Nautlius "Open With" dialog. 

This would be helpful because there are hundreds of executables on a Linux machine, and the alternative here is to type in the location of the application you want - a fact that has to be looked up with 'which firefox' or the like. DDoing this is well outside the normal user's abilities, and they shouldn't be expected to do this.

Hope this makes sense. I can provide a screenshot of the Nautilus "open with" dialog if that helps.

Reproducible: Always

Steps to Reproduce:
1. Get an attachment that isn't already configured to open automatically in a certain program.
2. Double click it.
3. In the Open With drop down, select "Other..."
4. Note how bloody hard it is to find the application you want.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I am quite sure that these bugs are similar, please comment if you think it is a different problem.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 397700
You need to log in before you can comment on or make changes to this bug.