If there is no internet connection, browser refuses to send request to pages served locally on 127.0.0.1

RESOLVED DUPLICATE of bug 339814

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 339814
8 years ago
8 years ago

People

(Reporter: P Roy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6

I am trying to do some web development work where I serve pages locally off python's development server. The pages load fine when the computer is connected to the internet, but the moment that connection is taken out (I reproduced the situation by disconnecting my ethernet cable), the browser will not even send a request to the server. A cached version of the page(probably) is being loaded.

Reproducible: Always

Steps to Reproduce:
1.start up django development server using 'python manage.py runserver'
2.disconnect ethernet cable and turn off wireless networking. open firefox and point to 127.0.0.1:8000
3.the page being developed by me uses AJAX, and it appears to display the last received XML response in flat text format
Actual Results:  
<blank>

Expected Results:  
[17/Dec/2009 23:18:18] "GET /xxx/yyy/zzz HTTP/1.1" 200 6516
[17/Dec/2009 23:18:18] "GET /xxx/yyy/zzzz HTTP/1.1" 200 1070
[17/Dec/2009 23:18:18] "GET /xxx/yyy/zzzzz HTTP/1.1" 200 2739
(this happened after I connected the ethernet cable back)

Comment 1

8 years ago
Looks to be a duplicate of Bug 432434 or Bug 339814

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 339814
You need to log in before you can comment on or make changes to this bug.