Last Comment Bug 535802 - Disable the Windows JIT debugger dialog when running mochitests
: Disable the Windows JIT debugger dialog when running mochitests
Status: RESOLVED FIXED
[fixed-lorentz]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg]
:
Mentors:
Depends on:
Blocks: 532400
  Show dependency treegraph
 
Reported: 2009-12-18 08:18 PST by Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg]
Modified: 2010-04-07 06:11 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.4-fixed


Attachments
Disable the crash dialog on Windows, rev. 1 (7.40 KB, patch)
2009-12-18 08:20 PST, Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg]
ted: review+
Details | Diff | Splinter Review

Description Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2009-12-18 08:18:21 PST
Because E10s tests now crash things on purpose, we need to disable the Windows JIT debugger dialog. Fortunately we already have code to do this if you set an envvar... I've just moved that code into a helper function and made it run in the child process as well, and set the envvar in automation.py.
Comment 1 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2009-12-18 08:20:01 PST
Created attachment 418382 [details] [diff] [review]
Disable the crash dialog on Windows, rev. 1
Comment 2 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2009-12-29 13:23:27 PST
http://hg.mozilla.org/mozilla-central/rev/c63aea2f8c16
Comment 3 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2009-12-29 13:23:44 PST
Oh, and http://hg.mozilla.org/mozilla-central/rev/6e9b8529e66b for build bustage.
Comment 4 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2010-03-24 07:58:32 PDT
http://hg.mozilla.org/projects/firefox-lorentz/rev/5c96da98f1cb
Comment 5 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2010-03-24 07:59:01 PDT
and http://hg.mozilla.org/projects/firefox-lorentz/rev/d8f5e444813b
Comment 6 Mike Beltzner [:beltzner, not reading bugmail] 2010-04-06 16:10:50 PDT
Blanket approval for Lorentz merge to mozilla-1.9.2
a=beltzner for 1.9.2.4 - please make sure to mark status1.9.2:.4-fixed
Comment 7 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2010-04-07 06:11:45 PDT
Merged into 1.9.2 at http://hg.mozilla.org/releases/mozilla-1.9.2/rev/84ba4d805430

Note You need to log in before you can comment on or make changes to this bug.