Top crash start_date and end_date should reflect data returned

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
9 years ago
a year ago

People

(Reporter: ozten, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
per chofmann in #breakpad

The TopCrashersSigRankAPI should populate start_date and end_date based on the data returned, not on the requested window.

Steps
1) Add a new product/version
2) Run cron
3) Go to new top crashers by signature page such as http://crash-stats.mozilla.com/topcrasher/byversion/Firefox/3.6b5

Expected:
Intro paragraph:
Top 198 Crashing Signatures 2009-12-18 07:00:00 through 2009-12-18 08:00:00.

Actual:
Top 198 Crashing Signatures 2009-12-04 08:00:00 through 2009-12-18 08:00:00.

Comment 1

9 years ago
Priority?

Comment 2

9 years ago
lower priority, but seems like it should be a simple fix.  I causes a bit of confusion when people start looking at the data just after a new product/version is set up.
(Assignee)

Updated

7 years ago
Component: Socorro → General
Product: Webtools → Socorro

Updated

7 years ago
Component: General → Webapp
Is this still a bug? Going to https://crash-stats.mozilla.com/topcrasher/byversion/Firefox/13.0a1 the line there reads:

"Top 300 Crashing Signatures. 2012-02-02 through 2012-02-09."

Comment 4

7 years ago
We were talking about this today, and I personally feel like the requested functionality would be more confusing for users.

Maybe we should add a different line with this detail?

Comment 5

5 years ago
This API call is gone.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Comment 6

5 years ago
Let's highlight it if the returned data range is different from the requested one and show the actual
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: TopCrashersSigRankAPI start_date and end_date should reflect data returned → Top crash start_date and end_date should reflect data returned

Updated

5 years ago
Duplicate of this bug: 779193

Comment 8

a year ago
This API call is gone, and so are the underlying data stores. Let's file a new bug if we still need this feature in the new UI.
Status: REOPENED → RESOLVED
Last Resolved: 5 years agoa year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.