Closed Bug 535844 Opened 15 years ago Closed 14 years ago

intermittent failure in test_storage_legacy_4.js

Categories

(Toolkit :: Password Manager, defect)

x86
Windows NT
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 535585

People

(Reporter: dholbert, Unassigned)

References

()

Details

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261160857.1261162799.22184.gz
WINNT 5.2 mozilla-central opt test everythingelse on 2009/12/18 10:27:37
s: win32-slave33

{
> TEST-UNEXPECTED-FAIL | e:\builds\moz2_slave\mozilla-central-win32-opt-unittest-everythingelse\build\xpcshell\tests\test_passwordmgr\unit\test_storage_legacy_4.js | test failed (with xpcshell return code: 1), see following log:
>   >>>>>>>
>   TEST-INFO | (xpcshell/head.js) | test 1 pending
> TEST-PASS | e:/builds/moz2_slave/mozilla-central-win32-opt-unittest-everythingelse/build/xpcshell/tests/test_passwordmgr/unit/head_storage_legacy_1.js | [anonymous : 132] 5 == 5
}

The whole "following log" chunk looks irrelevant to me -- it just has TEST-PASS lines from head_storage_legacy_1.js.  (a different test?)

There actually aren't any other mentions of test_storage_legacy_4.js in the entire log.  So, looks like don't have any more information about the failure at this point.

Definitely a randomorange bug, though -- the "guilty" changeset was a whitespace fix, http://hg.mozilla.org/mozilla-central/rev/0e6c2ecbb397
See Also: → 531328
OS: Linux → Windows NT
See bug 535565: we're failing at random spots in Windows Eo xpcshell tests, all with "(with xpcshell return code: 1)" and a useless error-free "following log".
Possibly related to bug 494105, although more likely to bug 535585.
No longer blocks: 438871
Status: NEW → RESOLVED
Closed: 14 years ago
No longer depends on: 535585
Resolution: --- → DUPLICATE
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.