Intermittent failure in js1_5/extensions/regress-371636.js | Numeric sort performance Expected value '(tint/tstr < 3)=true', Actual value '(tint/tstr < 3)=false'

RESOLVED DUPLICATE of bug 528284

Status

()

RESOLVED DUPLICATE of bug 528284
9 years ago
9 years ago

People

(Reporter: philor, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261438070.1261443241.5034.gz
Linux mozilla-central opt test everythingelse on 2009/12/21 15:27:50
s: moz2-linux-slave25

REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/mozilla-central-linux-opt-unittest-everythingelse/build/jsreftest/tests/jsreftest.html?test=js1_5/extensions/regress-371636.js | Numeric sort performance Expected value '(tint/tstr < 3)=true', Actual value '(tint/tstr < 3)=false'  item 1

Pretty sure that's the first time, since it's easy enough to file that I wouldn't expect that I'd have skipped over it.

Comment 1

9 years ago
I think we should give up on all jsreftests that attempt to compute or compare orders of complexity.  Nearly all of the intermittent jsreftests have been ones attempting to make some sort of perf evaluation.  We're not going to eliminate enough machine noise for them to be completely reliable, and they're a constant nuisance to everyone -- if only to track down that an "orange" is "ignorable" -- in the meantime.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 528284
(Reporter)

Updated

9 years ago
No longer blocks: 438871
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.