Intermittent failure in js1_5/extensions/regress-371636.js | Numeric sort performance Expected value '(tint/tstr < 3)=true', Actual value '(tint/tstr < 3)=false'

RESOLVED FIXED in mozilla1.9.3a1

Status

()

Core
JavaScript Engine
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: bc, Assigned: bc)

Tracking

({intermittent-failure})

Trunk
mozilla1.9.3a1
x86
Windows XP
intermittent-failure
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [test disabled])

(Assignee)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258048503.1258054126.7653.gz

REFTEST TEST-UNEXPECTED-FAIL |
file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-everythingelse/build/jsreftest/tests/jsreftest.html?test=js1_5/extensions/regress-371636.js
| Numeric sort performance Expected value '(tint/tstr < 3)=true', Actual value
'(tint/tstr < 3)=false'  item 1
Flags: in-testsuite+
(Assignee)

Updated

8 years ago
Whiteboard: [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258081555.1258086853.21997.gz#err2
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/12 19:05:55
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258070062.1258077904.19636.gz#err10
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/12 15:54:22
(Assignee)

Comment 3

8 years ago
mark random for windows debug

http://hg.mozilla.org/mozilla-central/rev/77d80f760516
http://hg.mozilla.org/tracemonkey/rev/c883d7e3c221
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [orange] → [orange][fixed-in-tracemonkey]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258234706.1258237662.16336.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/14 13:38:26
"s: moz2-win32-slave09"
REFTEST TEST-UNEXPECTED-FAIL | file:///E:/builds/moz2_slave/mozilla-central-win32-unittest-everythingelse/build/jsreftest/tests/jsreftest.html?test=js1_5/extensions/regress-371636.js | Numeric sort performance Expected value '(tint/tstr < 3)=true', Actual value '(tint/tstr < 3)=false'  item 1

Apparently it's a touch random for Windows non-debug, too.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258302559.1258304921.1925.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/15 08:29:19
"s: moz2-win32-slave28"
Blocks: 438871
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258555336.1258559260.6185.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258606944.1258609556.30031.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/18 21:02:24
"s: moz2-win32-slave26"

Comment 8

8 years ago
http://hg.mozilla.org/mozilla-central/rev/c883d7e3c221
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258663206.1258667421.17300.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/19 12:40:06  
"s: moz2-win32-slave34"
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-unittest-everythingelse/build/jsreftest/tests/jsreftest.html?test=js1_5/extensions/regress-371636.js | Numeric sort performance Expected value '(tint/tstr < 3)=true', Actual value '(tint/tstr < 3)=false'  item 1


So this still seems to be happening.  Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

8 years ago
that looks like opt. I have a patch I am testing along with the other oranges to mark this random for opt and debug windows. I'll land it later this evening.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258689499.1258691787.1000.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/19 19:58:19
"s: moz2-win32-slave16"
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-unittest-everythingelse/build/jsreftest/tests/jsreftest.html?test=js1_5/extensions/regress-371636.js | Numeric sort performance Expected value '(tint/tstr < 3)=true', Actual value '(tint/tstr < 3)=false'  item 1
(Assignee)

Comment 12

8 years ago
http://hg.mozilla.org/mozilla-central/rev/4c661affa445
http://hg.mozilla.org/tracemonkey/rev/23872e834580

mark random on windows for opt/debug.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED

Comment 13

8 years ago
Looks like this was incorrectly marked as fixed when the test was disabled.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [orange][fixed-in-tracemonkey] → [test disabled][orange]
Duplicate of this bug: 536298
Which would explain why I filed a duplicate of it last December (though not why we're suddenly seeing new Linux failures today).

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1274208621.1274209164.18963.gz
Linux mozilla-central opt test jsreftest, Started 14:50, finished 15:00, took
11mins
s: moz2-linux-slave27
REFTEST TEST-UNEXPECTED-FAIL |
file:///builds/slave/mozilla-central-linux-opt-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_5/extensions/regress-371636.js
| Numeric sort performance Expected value '(tint/tstr < 3)=true', Actual value
'(tint/tstr < 3)=false'  item 1

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1274916627.1274919969.24528.gz
Linux mozilla-central debug test jsreftest, Started 16:30, finished 17:27, took
57mins
s: moz2-linux-slave01
REFTEST TEST-UNEXPECTED-FAIL |
file:///builds/moz2_slave/mozilla-central-linux-debug-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_5/extensions/regress-371636.js
| Numeric sort performance Expected value '(tint/tstr < 3)=true', Actual value
'(tint/tstr < 3)=false'  item 1
Summary: js1_5/extensions/regress-371636.js - random failure on mozilla-central → Intermittent failure in js1_5/extensions/regress-371636.js | Numeric sort performance Expected value '(tint/tstr < 3)=true', Actual value '(tint/tstr < 3)=false'
Comment hidden (Treeherder Robot)
Depends on: 712837
Pretty thoroughly fixed by bug 712837, though.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago6 years ago
Resolution: --- → FIXED
Keywords: intermittent-failure
Whiteboard: [test disabled][orange] → [test disabled]
You need to log in before you can comment on or make changes to this bug.