Not all scrollbars respect layout.scrollbar.side

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
a year ago

People

(Reporter: jarauh, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091110 Gentoo Firefox/3.5.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091210 Thunderbird/3.0

The option "layout.scrollbar.side" determines whether scrollbars appear at the left or at the right of a window.  Currently, this only works for message windows.  It does not work, for example, for folder views and for the "about:config"-window.

Reproducible: Always

Steps to Reproduce:
1. Set layout.scrollbar.side to 3
2. Open some new windows with scrollbars and check the side of the scrollbar.

Actual Results:  
Only scrollbars in message windows are on the left.

Expected Results:  
All scrollbars on the left hand side.
OS: Linux → All

Comment 1

7 years ago
It also doesn't work for the Add-Ons page. As with about:config the scrollbar stubbornly appear on the right.

Not sure what the OP means by "message windows". All regular web pages work as expected. It is only some of the browser's built-in pages that I have problems with. However about:support is one that does correctly have the scroll bar on the left.

Comment 2

7 years ago
Oops. Sorry this bug is for Thunderbird. My comment #1 refers to Firefox 4.

Updated

7 years ago
Depends on: 656833

Comment 3

6 years ago
reporter, do you still see this problem when using a current version?
Component: General → Untriaged
Whiteboard: [closeme 2012-12-10]
(Reporter)

Comment 4

6 years ago
The problem is still there in Thunderbird 10.0.7:
Windows with emails have the scroll bar on the left, but the list of mail folders has its scroll bar on the right, and also the list of emails in a given folder has its scroll bar on the right.

Comment 5

6 years ago
The scroll bar on the Add-Ons pane is also on the right as it also still is in Firefox 17.

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [closeme 2012-12-10]

Updated

6 years ago
Component: Untriaged → Mail Window Front End

Comment 6

a year ago
Is this still present in latest Thunderbird version?
Flags: needinfo?(jarauh)
Whiteboard: [closeme 2017-05-15]

Comment 7

a year ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(jarauh)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2017-05-15]
You need to log in before you can comment on or make changes to this bug.