Closed Bug 536404 Opened 10 years ago Closed 10 years ago

When composing an S/MIME encrypted email, no padlock is shown at bottom right of window

Categories

(Thunderbird :: Security, defect)

defect
Not set

Tracking

(blocking-thunderbird3.0 .1+, thunderbird3.0 .1-fixed)

VERIFIED FIXED
Thunderbird 3.1a1
Tracking Status
blocking-thunderbird3.0 --- .1+
thunderbird3.0 --- .1-fixed

People

(Reporter: dave, Assigned: sgautherie)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.6) Gecko/20091201 SUSE/3.5.6-4.1 Firefox/3.5.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.5) Gecko/20091130 SUSE/3.0.0-12.1 Thunderbird/3.0

In TB2 the compose window shows a padlock at the bottom right of the compose window when you specify 'encrypt this message'. This padlock is absent in TB3.

TB3 does show the 'signed email' icon.

Reproducible: Always

Steps to Reproduce:
1. Open compose window with 'write' button
2. Select security > encrypt this message
Actual Results:  
No padlock icon - or anything else to show the message is encrypted.

Expected Results:  
Should be a padlock icon at bottom right - as in TB2

If you specify 'digitally sign this message' you do get an icon for that - as in TB2.
Component: General → Security
QA Contact: general → thunderbird
Version: unspecified → 3.0
Confirmed.
I'm also experiencing same issue in Tb 3 ( Linux ).
This problem is also in latest nightly build.
Status: UNCONFIRMED → NEW
blocking-thunderbird3.0: --- → ?
Ever confirmed: true
WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b6pre) Gecko/20100104 Lanikai/3.1a1pre
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
(In reply to comment #2)
> WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b6pre)
> Gecko/20100104 Lanikai/3.1a1pre

Attachment 419562 [details] [diff] actually fixed this for 3.1/3.2. Therefore changing resolution to fixed. I'll attach the patch here so that we can get it into the 3.0 branch.
Assignee: nobody → sgautherie.bz
Blocks: 442730
blocking-thunderbird3.0: ? → .1+
Keywords: regression
Resolution: WORKSFORME → FIXED
Target Milestone: --- → Thunderbird 3.1a1
This is the un-bitrotted version of attachment 536404 [details] [diff] [review] and already has r=mkmelin.

a=Standard8 as this fixes the issue.
Attachment #420097 - Flags: review+
Attachment #420097 - Flags: approval-thunderbird3.0.1+
OS: Linux → All
Hardware: x86 → All
Comment on attachment 420097 [details] [diff] [review]
The fix
[Checkin: Comment 5]


http://hg.mozilla.org/releases/comm-1.9.1/rev/38b6563f2ef8
Attachment #420097 - Attachment description: The fix → The fix [Checkin: Comment 5]
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.7) Gecko/20100107 Shredder/3.0.1pre V. Fix
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.