[OOPP] Crash installing Move Player [@ _filbuf] [@ mozilla::ipc::RPCChannel::DebugAbort]

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: u88484, Unassigned)

Tracking

({crash, crashreportid, regression})

Trunk
x86_64
Windows 7
crash, crashreportid, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
1) Go to http://www.fox.com/fod/includes/moveinstall/index.htm
2) Click download, save the file
3) Install plugin
4) Clip on install page starts playing
5) Click the "Yes" button to agree that the video with audio started playing
6) Browser crashes (no crash report)
7) Browser restarts then crashes again once the same clip starts playing (Bug 535576)
8) Browser restarts, restore the 'Move Player Install' tab
9) Video starts playing on fox page then another crash

I looked in the about:crashes and had the crash for bug 535576 and the following two

Crash report:

http://crash-stats.mozilla.com/report/index/bp-7f4c88e0-61ef-416a-a7db-7408a2091223
http://crash-stats.mozilla.com/report/index/bp-95bb3c5d-db5e-43e3-bd9d-430242091223

Crash stack for first crash ID:

Firefox 3.7a1pre Crash Report [@ Abort ]
Search Mozilla Support for Help
ID: 7f4c88e0-61ef-416a-a7db-7408a2091223
Signature: Abort

    * Details
    * Modules
    * Raw Dump
    * Extensions
    * Comments

Signature	Abort
UUID	7f4c88e0-61ef-416a-a7db-7408a2091223
Time 	2009-12-23 13:53:19.103753
Uptime	154
Last Crash	156 seconds before submission
Product	Firefox
Version	3.7a1pre
Build ID	20091223050727
Branch	1.9.3
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	AuthenticAMD family 15 model 104 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x0
User Comments	
Processor Notes 	
Related Bugs

OPEN

        * 536401 NEW [OOPP] Minefield crashes while Vimeo video attempts to load. [@ Abort ]
        * 535298 NEW [OOPP] Loading https://www.mozilla.com/en-US/plugincheck/ crashes the browser [@ Abort ]
        * 535280 NEW [OOPP] Videos on youporn.com crash browser after the videos end (NSFW Links) [@ Abort ]

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	Abort 	xpcom/base/nsDebugImpl.cpp:376
1 	mozcrt19.dll 	_filbuf 	
2 	xul.dll 	mozilla::ipc::RPCChannel::DebugAbort 	ipc/glue/RPCChannel.cpp:393
3 	nspr4.dll 	PR_DestroyLock 	
4 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:134
5 	xul.dll 	Pickle::Pickle 	ipc/chromium/src/base/pickle.cc:38
6 	xul.dll 	mozilla::plugins::PPluginScriptableObjectParent::CallHasProperty 	obj-firefox/ipc/ipdl/PPluginScriptableObjectParent.cpp:417
7 	xul.dll 	mozilla::plugins::PluginScriptableObjectParent::ScriptableHasProperty 	dom/plugins/PluginScriptableObjectParent.cpp:495
8 	xul.dll 	NPObjWrapper_GetProperty 	modules/plugin/base/src/nsJSNPRuntime.cpp:1310

Second crash report:

Firefox 3.7a1pre Crash Report [@ ntdll.dll@0x22272 ]
Search Mozilla Support for Help
ID: 95bb3c5d-db5e-43e3-bd9d-430242091223
Signature: ntdll.dll@0x22272

    * Details
    * Modules
    * Raw Dump
    * Extensions
    * Comments

Signature	ntdll.dll@0x22272
UUID	95bb3c5d-db5e-43e3-bd9d-430242091223
Time 	2009-12-23 13:53:47.43590
Uptime	24
Last Crash	27 seconds before submission
Product	Firefox
Version	3.7a1pre
Build ID	20091223050727
Branch	1.9.3
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	AuthenticAMD family 15 model 104 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0xffffffff80646e89
User Comments	
Processor Notes 	
Related Bugs

OPEN

        * 521849 NEW SSL broken on windows 7, involves FIPS PR_Lock/nsSSLIOLayerHelpers::isKnownAsIntolerantSite, sometimes crash [@ ntdll.dll@0x22272]

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	ntdll.dll 	ntdll.dll@0x22272 	
1 	nspr4.dll 	PR_Lock 	nsprpub/pr/src/threads/combined/prulock.c:233
2 	xul.dll 	mozilla::MutexAutoLock::MutexAutoLock 	obj-firefox/dist/include/mozilla/Mutex.h:180
3 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:92
4 	xul.dll 	mozilla::plugins::PStreamNotifyParent::Call__delete__ 	obj-firefox/ipc/ipdl/PStreamNotifyParent.cpp:82
5 	xul.dll 	mozilla::plugins::PluginInstanceParent::AnswerPStreamNotifyConstructor 	dom/plugins/PluginInstanceParent.cpp:289
6 	xul.dll 	mozilla::plugins::PPluginInstanceParent::OnCallReceived 	obj-firefox/ipc/ipdl/PPluginInstanceParent.cpp:893
7 	xul.dll 	mozilla::plugins::PPluginModuleParent::OnCallReceived 	obj-firefox/ipc/ipdl/PPluginModuleParent.cpp:415
8 	xul.dll 	mozilla::ipc::RPCChannel::DispatchIncall 	ipc/glue/RPCChannel.cpp:347
9 	xul.dll 	mozilla::ipc::RPCChannel::Incall 	ipc/glue/RPCChannel.cpp:332
10 	xul.dll 	mozilla::ipc::RPCChannel::OnMaybeDequeueOne 	ipc/glue/RPCChannel.cpp:267
11 	xul.dll 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:326
12 	xul.dll 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:334
13 	xul.dll 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:434
14 	xul.dll 	mozilla::ipc::DoWorkRunnable::Run 	ipc/glue/MessagePump.cpp:75
15 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527
16 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:142
17 	xul.dll 	xul.dll@0x9a4b63 	
18 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:194
19 	user32.dll 	user32.dll@0x16e4b 	
20 	xul.dll 	_IsNonwritableInCurrentImage 	
21 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:168
22 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:174
23 	nspr4.dll 	PR_GetEnv 	
24 	xul.dll 	nsAppShell::Run 	widget/src/windows/nsAppShell.cpp:239
25 		@0x77d6ffff 	
26 		@0x7786ffff 	
27 		@0x7746ffff
(Reporter)

Comment 1

9 years ago
Please note I can't actually reproduce this after uninstalling the plugin and trying again.  I think I did something special like click the yes button on the one page before the video begun and the browser crashed as the page was loading the plugin while switching to the other tab to begin playing the fox video and that page also crashed.

I can reproduce the crash after installing the plugin (the one where the crash reporter doesn't catch it but windows crash reporter does).  The browser hangs just before that crash.
(Reporter)

Comment 3

9 years ago
Might be but I can't reproduce it.  See also but 536666 which has a like signature at the beginning.  That bug is the only crash that I get all the time.

Comment 4

9 years ago
STR:

1. Set dom.ipc.plugins.enabled to true and restart the browser
2. Load: http://www.novinky.cz/domaci/176127-obloha-bude-v-noci-plna-padajicich-hvezd.html
3. Click to play the video and wait for the video to finish playing, including the time-lapse sky animation at the end.  Once all has played, plug-in will crash
4. You will get the plug-in crashed notification.  Click to submit.
5. Refresh the page.  Now the whole browser crashes.

http://crash-stats.mozilla.com/report/index/bp-339243c2-b8bc-4b8e-a4c5-4189f2100119

Comment 5

9 years ago
That's the parent-side crash report... do you also have a crash ID for the child-side crash?

Comment 7

9 years ago
(In reply to comment #5)
> That's the parent-side crash report... do you also have a crash ID for the
> child-side crash?

http://crash-stats.mozilla.com/report/index/bp-9a09c004-cec0-49b8-bfec-f87362100119

Comment 8

9 years ago
I'm also crashing (whole browser) immediately, when trying to play video at: http://watch.ctv.ca/news/

http://crash-stats.mozilla.com/report/index/bp-539cfa05-db7b-4b63-bda5-f14cf2100120
http://crash-stats.mozilla.com/report/index/bp-616111fe-dabb-4cde-8e27-9e6122100120

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20100120 Minefield/3.7a1pre ID:20100120043108

Comment 9

9 years ago
I can no longer reproduce comment 4 step 5, so this appears to be fixed by bug 538239

Comment 10

9 years ago
I'll mark this resolved: please reopen if you see this using nightlies from today or later (with crash report IDs if possible).
Blocks: 531142
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ _filbuf] [@ mozilla::ipc::RPCChannel::DebugAbort]
You need to log in before you can comment on or make changes to this bug.