Closed Bug 537218 Opened 10 years ago Closed 6 years ago

Mobile google images site is broken for some user agent values

Categories

(Web Compatibility :: Mobile, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: moz_poro, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b6pre) Gecko/20091230 Namoroka/3.6b6pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b6pre) Gecko/20091230 Namoroka/3.6b6pre

Mobile google images site seems to change its functionality based on the user-agent value. For some user agent values the image search result page is badly broken.

Reproducible: Always

Steps to Reproduce:
1. Set general.useragent.override to "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b6pre) Gecko/20091230 Namoroka/3.6b6pre Maemo Browser 1.7.5 RX-51 N900", basically add the "Maemo Browser 1.7.5 RX-51 N900" to the useragent.
2. Go to the url, enter some words to text entry, for example "mozilla"
3. A result page with "Tap on an image to see its source" is opened.
4. Click on any image
Actual Results:  
Image is shown permanently.

Expected Results:  
Image is shown quickly, then it is replaced with "in progess" spinner.

If step 1 is skipped the image result pages works correctly (note that the result page looks different, see step 3.)

The test sequence also works correctly on "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6" even if the step 1 is performed so the problem is more likely in Mozilla side, not in Google.
Attached file Simple test page
I have narrowed this down to the attached simple test page.

Basically the problem is that setting elements style.backgroundImage to something in the form url(something) actually changes it to form url('something'). The test page shows that "They match" on "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6", "Internet Explorer 8.0.6001.18702" and "Konqueror 4.1.4".

But on "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b6pre) Gecko/20091230 Namoroka/3.6b6pre" "They DON'T match".

I don't know if this is a bug or a feature but it breaks the Mobile version of Google Images when using Maemo Browser.
This bug was introduced by the changes in bug 478160. A quick and dirty fix of removing aReturn.Append(PRUnichar('"')); calls from nsStyleUtil::AppendEscapedCSSString would fix this. But that propably caused mayhem and chaos somewhere else.
Anybody have a contact at google that could fix this?  OP also stated (on IRC) the same thing happens on the iPhone.
Assignee: nobody → english-us
Component: General → English US
Product: Core → Tech Evangelism
QA Contact: general → english-us
Status: UNCONFIRMED → NEW
Ever confirmed: true
No, I said the same thing happens in Firefox using the iPhone UA.
(In reply to comment #3)
> Anybody have a contact at google that could fix this?

Any progress with this?
Depends on: 478160
Blocks: 478160
No longer depends on: 478160
(In reply to comment #0)
> 3. A result page with "Tap on an image to see its source" is opened.

I don't see such a result page, even with that useragent override.

Is this still present?
(In reply to comment #6)
> (In reply to comment #0)
> > 3. A result page with "Tap on an image to see its source" is opened.
> 
> I don't see such a result page, even with that useragent override.

Now it seems that Google returns the "simpler" mobile result page with that useragent. So the problem is kind of fixed. I would like to see that more advanced result page to make a comeback though, it was more useful (when it worked) :)
closing as INVALID
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Mobile
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.