indexing unexpectedly wipes out message which I look at - compact related?

RESOLVED DUPLICATE of bug 479064

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 479064
8 years ago
7 years ago

People

(Reporter: denis.barmenkov, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Build Identifier: 3.0 ENG

At some unstable circumstances TB launches indexing process and blanc message preview window; it may be two different mail folders.

After few seconds indexing done but I shall go to message, select it and scroll to place where 'clever indexing engine' breaks reading.

Is it possible cut off index engine rights and make it do their work as screensaver?
In cases:
- system screensaver is active
- TB window is minimized
But not in case 'window not active' because I can read message even from non-active window :)

Reproducible: Sometimes

Steps to Reproduce:
Waching 'smarty' index engine behaviour


Expected Results:  
unbreakable mail reading

Comment 1

8 years ago
indexing is not likely to be the cause.
do you have automatic compact set?
Version: unspecified → 3.0
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> indexing is not likely to be the cause.
> do you have automatic compact set?

yes, automatic compact set to run if there will 2500KB free after process.

Anyway, background tasks must be shutted down when I read the mail.
:)

Comment 3

8 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > indexing is not likely to be the cause.
> > do you have automatic compact set?
> 
> yes, automatic compact set to run if there will 2500KB free after process.

is problem gone when you turn off auto compact?
Severity: major → enhancement
Whiteboard: dupme

Updated

8 years ago
Severity: enhancement → normal
(Reporter)

Comment 4

8 years ago
now I turned autocompact off so I mean watch about for a week and report here.
(Reporter)

Comment 5

8 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > indexing is not likely to be the cause.
> > > do you have automatic compact set?
> > 
> > yes, automatic compact set to run if there will 2500KB free after process.
> 
> is problem gone when you turn off auto compact?

another opinion:
TB shall determine moment when to process background tasks, for sample:
- when TB window is minimized
- when message preview pane hidden (by pressing F8 button)
- when user not using program, like screen saver policy: TB window doesn't receive any mouse/keyboard events for at least 5 minutes

Updated

8 years ago
Summary: indexing unexpectedly wipes out message which I look at → indexing unexpectedly wipes out message which I look at - compact related?
Whiteboard: dupme → [revisit 2010-02-10] dupme
Blank message pane itself is very easily produced with Tb 3.0.4.
0. Folder pane view = All Folders
1. Create new local mail folder(say XX), copy several mails to XX,
   show "Order Received" column(offset in mail folder file),
   sort by this column in ascending order
2. Move mail(s) to Trash, and move mail(s) back to XX from Trash
3. View a mail in XX
4. Compact at folder context menu of XX
   => Offset("Order Received" column value) is changes because campacted
   => Message pane is blanked out
AFAIR, it's already reported phenomenon.

Bug opener, set next pref, restart Thunderbird(restart is mandatory), and show "Order Received" column.
> mail.purge.ask = true
By mail.purge.ask=true, dialog is displayed before start of auto-compact.
Check whether "Order Received" column value was changed after compaction or not, please.
(Reporter)

Comment 7

8 years ago
(In reply to comment #6)
> Blank message pane itself is very easily produced with Tb 3.0.4.
> 0. Folder pane view = All Folders
> 1. Create new local mail folder(say XX), copy several mails to XX,
>    show "Order Received" column(offset in mail folder file),
>    sort by this column in ascending order
> 2. Move mail(s) to Trash, and move mail(s) back to XX from Trash
> 3. View a mail in XX
> 4. Compact at folder context menu of XX
>    => Offset("Order Received" column value) is changes because campacted
>    => Message pane is blanked out
> AFAIR, it's already reported phenomenon.
> 
> Bug opener, set next pref, restart Thunderbird(restart is mandatory), and show
> "Order Received" column.
> > mail.purge.ask = true
> By mail.purge.ask=true, dialog is displayed before start of auto-compact.
> Check whether "Order Received" column value was changed after compaction or
> not, please.

Order Received column changed.
(In reply to comment #7)
> Order Received column changed.

It's an evidence that compact was executed on the folder while you are viewing a mail. 

> yes, automatic compact set to run if there will 2500KB free after process.

If you don't frequently move or delete big mails, auto-compact is not so frequently invoked if 2500KB is set. Keep mail.purge.ask=true always(never check [ ] do this automatically ... or something in dialog), and reply "No"(or "Cancel") to dialog before start of auto-compact, if you are doing important work with a folder which will probably be compacted. Auto-compact will be scheduled again sooner or later, so "Cancel" won't produce big issue, unless you never reply OK".
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 9

8 years ago
My workaround was set "autocompact" to "off" :)

Comment 10

7 years ago
Even if Auto Compact is the root cause, this should be considered incorrect behavior.  Having Auto Compact enabled saves disk space.  Losing the message being displayed at the time it starts, and having the message list position change as well, should not happen simply because the disk is being cleaned up.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: [revisit 2010-02-10] dupme
Duplicate of bug: 479064
You need to log in before you can comment on or make changes to this bug.