Closed Bug 537474 Opened 10 years ago Closed 10 years ago

Cannot open Browse all Add-ons with browser.link.open_newwindow set to 1

Categories

(Firefox :: General, defect, minor)

3.6 Branch
defect
Not set
minor

Tracking

()

RESOLVED FIXED
Firefox 3.7a1
Tracking Status
status1.9.2 --- final-fixed

People

(Reporter: hseldon, Assigned: dao)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2b6pre) Gecko/20100101 Namoroka/3.6b6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2b6pre) Gecko/20100101 Namoroka/3.6b6pre

Firefox does not visit the add-on's home page when you open the add-ons window, select an add-on which has a home page, right click the add-on and select "visit home page".

Reproducible: Always

Steps to Reproduce:
1.set browser.link.open_newwindow=1
2.uncheck "always show the tab bar"
3.Open the add-ons window. Select an add-on which has a home page. Right click the add-on and select "Visit Home Page".
Actual Results:  
Firefox remains on the currently open page and does not go to the add-on's home page. 

Expected Results:  
Firefox should go to the add-on's home page.

If you perform the same steps in Firefox 3.5, the add-on's home page opens as expected.
Version: unspecified → 3.6 Branch
Looks like there are not any dupes, new. Can reproduce using Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091231 Minefield/3.7a1pre

Only need to set browser.link.open_newwindow =1 to reproduce.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Not Visiting Home Page in Add-ons with Tab Bar turned off and browser.link.open_newwindow=1 → Cannot open Browse all Add-ons with browser.link.open_newwindow set to 1
Assignee: nobody → dao
Blocks: 514310
Status: NEW → ASSIGNED
Component: Tabbed Browser → General
Flags: blocking-firefox3.6?
OS: Windows 7 → All
QA Contact: tabbed.browser → general
Hardware: x86_64 → All
Attached patch fix typoSplinter Review
Attachment #419778 - Flags: approval1.9.2.1?
http://hg.mozilla.org/mozilla-central/rev/4e8eb0e5e8c9
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
Flags: in-testsuite+
Blocking, please land on 1.9.2 immediately.
Flags: blocking-firefox3.6? → blocking-firefox3.6+
Attachment #419778 - Flags: approval1.9.2.1?
You need to log in before you can comment on or make changes to this bug.