Closed Bug 537598 Opened 14 years ago Closed 4 years ago

Windows address book (OE Contacts) hangs if two searches are submitted

Categories

(MailNews Core :: Address Book, defect)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: neil, Unassigned)

References

Details

(Keywords: hang)

Steps to reproduce problem:
1. Start a query against the outlook address book
2. Before the query has finished, start another query

The second query tries to stop the first query using PR_Interrupt, but this seems to have no effect. The first query eventually tries to proxy its results back to the main thread. However the second query is trying to open the Windows address book, which is trying to proxy over to the first query's thread since it already has the Windows address book open. This results in a deadlock.
Severity: major → critical
neil, does this still reproduce?
I don't see why not, but I don't know whether I have an up-to-date build and an outlook express address book on the same machine or not.
any other outlook testers?
Flags: needinfo?
Can we clarify a little what the problem is. One person talks about "Outlook" (which is part of MS Office), another about "Outlook Express" (the free e-mail client on XP which has long been replaced by MS). The title of the bug contains "OE", so "Outlook Express".

I am sorry if this is a silly question, but what does "Start a query against the outlook address book" mean? Does this mean you use an LDAP directory server where the server is the MS Exchange server? If this was the case, you need a tester in a corporate environment where an MS Exchange server is used.

Once the submitter clarifies how to reproduce the problem, it will be easier to find someone willing to test this in the appropriate environment.
Flags: needinfo?

OE islong gone

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.